Support

Home Forums Event Espresso Premium Critical error with EventEsspresso upgrade

Critical error with EventEsspresso upgrade

Posted: June 7, 2022 at 11:51 am


rachel@harrisonsmith.me.uk

June 7, 2022 at 11:51 am

Hello, I got this fatal error when I try to update the Event espresso plug in. I’m running WordPress 6.0 and Event Espresso Version 4.10.30.p

Can you tell me what I need to do to resolve it.

Thanks
E_COMPILE_ERROR was caused in line 4012 of the file /home/th20qbdy/public_html/wp-content/plugins/event-espresso-core-reg/core/admin/EE_Admin_Page.core.php. Error message: Default value for parameters with a class type hint can only be NULL


Tony

  • Support Staff

June 8, 2022 at 4:50 am

Hi there,

That error is due to the PHP version in use on the site, right now the server has PHP5.6 installed but Event Espresso currently requires PHP7.1 as a minimum.

I recommend contacting your host and have them update the version of PHP in use on the server to PHP7.4 (the highest version of PHP7).

PHP5 is now end of life and is no longer maintained, see here: https://www.php.net/supported-versions.php

The latest version of PHP is PHP8, however Event Espresso is not fully compatible with it at this time so PHP7.4 is the recommended version.

The support post ‘Critical error with EventEsspresso upgrade’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso