Support

Home Forums Event Espresso Premium Chinese Characters Not Showing Up On Export

Chinese Characters Not Showing Up On Export

Posted: September 11, 2018 at 4:58 pm


John Atkins

September 11, 2018 at 4:58 pm

Hello,

This is how it appears like on WordPress when I click on View Registration Details:
https://imgur.com/VoYM5PH

This is how it appears when I open the CSV file generated from the “All Registrations CSV Report” button:
https://imgur.com/H5jz8fQ

I’m not sure if it’s an export issue or an Excel issue. Please advise.


Josh

  • Support Staff

September 11, 2018 at 8:31 pm

Hi,

You’ll probably need to follow these steps when importing the CSV to Excel:

https://stackoverflow.com/a/6488070

For what it’s worth, I checked, this is how the CSV appears in Apple Numbers:
https://slack-files.com/T02SY781D-FCSPCLAFR-2d4abaec67


John Atkins

September 17, 2018 at 4:36 pm

I was not able to follow those steps, as I wasn’t able to find “Import External Data” on my version of Excel (2016). It also wouldn’t really be easy to do as double-clicking the file and seeing the correct text since I would have to import the CSV each and every time I need to open the file.

After some further reading in the stackoverflow link, there’s a post from the user Elmue that I found relevant: “If you put the same values into a HTML file and save that file as UTF8 file with BOM with the file extension XLS you will get the correct result.”

Perhaps something like this might be what EventEspresso implement in a future update? Or perhaps an option to export as XLS(X) or just a HTML file? In the meanwhile I don’t have a solution to actually see the gibberish without having to install something like OpenOffice on my Windows machine.


Tony

  • Support Staff

September 18, 2018 at 3:26 am

Perhaps something like this might be what EventEspresso implement in a future update?

We had this in the export before we added the batch system, you can switch to that, but you’ll need to add some code to your wp-config.php file.

Add this:

define( 'EE_USE_OLD_CSV_REPORT_CLASS', true );

Add the above to a line above where it says:

/* That's all, stop editing! Happy blogging. */

The export will then include the UFT-8 BOM by default.

Or perhaps an option to export as XLS(X) or just a HTML file?

We don’t have any plans to add any Excel specific formats to EE.


John Atkins

September 21, 2018 at 5:22 pm

Thanks Tony, that worked perfectly, after exporting again the Chinese characters appeared just fine.

Because it’s using the old CSV export method (I think), it doesn’t have that longer filename with the date/times the new exports have, which was a really nice feature now that I don’t have it anymore.

Any chance the current export method might include the UFT-8 BOM by default?


Tony

  • Support Staff

September 24, 2018 at 4:41 am

I’ve created a ticket to investigate adding the UTF-8 BOM to the batch system CSV’s to a future version of EE, however as it stands you’ll need to use the above workaround.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Tony 4 hours, 38 minutes ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!