Support

Home Forums Event Espresso Premium Charged Multiple Times but listed as Pending Payment

Charged Multiple Times but listed as Pending Payment

Posted: June 12, 2014 at 5:50 pm


Delray Wannemcher

June 12, 2014 at 5:50 pm

I am receiving the error “This registration step could not be completed. Please refresh the page and try again” on the final step of registration – paying by credit card.

I read that it could be caused by WordFence. I tried deactivating the plugin, and submitted a registration and the problem still persisted.

I was able to register by invoice which worked fine – correct emails sent and correctly entered as registrant. But when I registered and tried to pay by credit card, I received the error message: “This registration step could not be completed. Please refresh the page and try again”.

The message occurred after entering credit card details and clicking “pay”. No emails were sent, but my card was still charged and I was entered into the system as a registrant, but with no transaction and as “pending payment”.

When I refreshed the page, I was actually charged again.

The site is using Authorize.net AIM for payment. The site was correctly registering visitors and processing payments on Monday. Since then, no changes have been made.

https://www.fsxinterlinked.com/sponsor-fsx/westlake-village/
EE4
WP 3.9.1


Dean

June 13, 2014 at 6:30 am

One issue, is that your site is loading jQuery version 1.7.2. The latest version that ships with WordPress is 1.10.0. Event Espresso ideally requires 1.8.3 as a minimum.

That being said, I ran a test registration on your site (with fake card details) and it processed everything correctly and I could see no specific errors, jQuery or otherwise.

Can you provide a breakdown of the steps that leads to the issue please?

Also what browser are you using?

Does the issue happen every time?

Also, do you have any caching plugins installed?


Delray Wannemcher

June 13, 2014 at 7:28 am

I reviewed your test registration, and it was entered into the system as “Pending Payment”, so it seems it did not work, right? Or would this be a default of fake card details and authorize.net declining it?

Steps to reproduce error:
1. Selected ticket from ticket selector > clicked “Register Now”
2. Completed registration form > clicked “Proceed to Payment Options”
3. Selected option: Pay by Credit Card
4. Entered real credit card details > Clicked “Finalize Registration”
5. Error message was shown: “This registration step could not be completed. Please refresh the page and try again” and I stayed on the same page with all fields still complete.

I checked with Authorize.net, and payment was successfully captured. In the “Registrations” in the WP Admin site, I was registered, but with the status “Pending Payment”, even though payment was taken. Also, no emails were sent.

Also, the major problem is, the error message says “Please refresh the page and try again.” But when the page is refreshed the card is charged again.

I am testing in Chrome, and it has happened every time since the problem was reported yesterday. But a customer that was charged multiple times and said they tested in both IE and Firefox.

No caching plugins installed.

The only change I made, was I recently updated my Authorize.net transaction key on Monday. But after updating, I submitted a test transaction and it went through fine.


Delray Wannemcher

June 13, 2014 at 11:14 am

Hi Dean,

Please let me know when you will be testing, because for the time being I am going to disable payment by credit card, and only allow invoicing just to ensure no more registrants are charged multiple times.

Thanks,

ALex


Lorenzo Orlando Caum

  • Support Staff

June 14, 2014 at 12:21 pm

Hi Alex,

You are currently running EE 4.1.8. The latest version is 4.2.5. Could you please backup your WordPress and update to the current software?

Here is a copy of the changelog so you can see the changes since that version:

http://eventespresso.com/wiki/ee4-changelog/#4.1.8


Lorenzo


Delray Wannemcher

June 18, 2014 at 10:36 am

Hi Lorenzon,

On our development server, I updated to EE 4.2.5 and also updated jQuery to 1.8.3, but I still have the same problem.

Any suggestions? I can give you access to the development site, but you will need to change your host file.

Please let me know.

– Alex


Dean

June 18, 2014 at 11:52 pm

Hi,

Update to the latest jQuery just to be sure, 1.8.3 might be a minimum but it is still better to be on the latest version that ships with WordPress.

Really it is hard to say what is occurring as your development site is not accessible.

What type of server are you using (for both the live site and development)?

Have you made sure that there is no caching (whilst testing) active?


Delray Wannemcher

June 19, 2014 at 8:30 am

Our theme is not currently coded to work with higher than 1.8.3. But we will make a point to update the theme to make it work in the future.

You can access the development site by changing your host file to comment out the IPs as follows:
#66.175.208.121 fsxinterlinked.com
#66.175.208.121 http://www.fsxinterlinked.com

The development site is hosted on WP Engine, but we previously disabled caching. The production site has no caching system.

Both servers are Linux.


Delray Wannemcher

June 19, 2014 at 8:32 am

Sorry, with regards to the host file, add those two IPs without the ‘#’ in front, and you will see the development site.


Delray Wannemcher

June 20, 2014 at 11:09 am

Hi,

Are you able to help me with this problem? Would buying support tokens help get his resolved?

Please let me know.

Alex


Tony

  • Support Staff

June 20, 2014 at 3:18 pm

Hi Alex,

Can you provide us with temporary Admin login details for the live site please?

We can not test the transactions on the dev server as, although our machine will be directed to the dev server (due to modifying the hosts file) the gateway response will not (they will responed to the domain name, which will use a standard DNS lookup and go to your live site’s IP)

So we’ll need to enable AIM for a short period, run through a registration and capture the details so we can investigate further.

If that is ok please send login details via https://eventespresso.com/send-login-details/

Please note, we may also need to enable WP_Debug, again for long enough to run through a registration so FTP details would also be appreciated in this case.


Delray Wannemcher

June 20, 2014 at 3:35 pm

Hi Tony,

I will send you the admin credentials via the send login details form. Currently our server is not setup to have ftp as we previously needed to move away from WP Engine as the plugin was not working. So, with the admin credentials, I will include our developers email, who will enable WP-debug when you tell him during your testing, and he will send you the error and log files if you need.

Enable AIM should be fine for a short period of time. During now peak hours would be best.

Thanks,

Alex


Tony

  • Support Staff

June 20, 2014 at 5:28 pm

Hi Alex,

We have run some test registrations on both the Live and Dev site and can not reproduce the “This registration step could not be completed. Please refresh the page and try again” error.

The registrations run through and although using fake card details (so the payment declines) no unexpected errors are thrown.

Here is the result of the test last registration – http://take.ms/nIxXn

This is displayed after clicking the ‘Finalize Registration’ button.

Is there a specific selection needed to throw the error?


Delray Wannemcher

June 21, 2014 at 3:22 pm

Tony,

I don’t believe there is a specific section to cause the error. I just tried and the error still occurred. You can see the screen shots here: https://www.fsxinterlinked.com/wp-content/uploads/2014/06/payment-error.jpg

It shows the error message and not advancing to the confirmation page, the registration entered as “pending payment”, and the payment captured at Authorize.net.

I created a test ticket of $1, and used a real credit card.

– Alex


Delray Wannemcher

June 21, 2014 at 3:24 pm

Also, just noticed that no “reg code” was assigned to the registrant when the error occurred.


Tony

  • Support Staff

June 23, 2014 at 4:06 am

I’ve just ran a registration on the same ticket, with false credit card data (we don’t test real credit card data) and again could complete the registration.

Have you tried clearing you browsers cache? It looks like you are using chrome, here are instructions to do so: https://support.google.com/chrome/answer/95582

I am however a little confused as to how AIM could actually communicate with the dev site. When altering your hosts file your are instructing your computer not use DNS but to use the IP address you assigned in your hosts file. So in your case you override your domain’s public IP with another which directs your browser to your dev server….

The problem comes when you send a request to AIM, it will come from your domain, AIM will respond using that domain, however AIM will respond to your live server not dev (as your domain will resolve to the live site IP)

Combine that with the fact that SSL communications will completely ignore your hosts file. As an example you can test this by adding:

127.0.0.1 http://www.facebook.com

to your hosts file – http://take.ms/ZOWrG

Then ping http://www.facebook.com (it now resolves to 127.0.0.1) http://take.ms/jWjVp

Now in your browser go to https://www.facebook.com (notice it correctly resolves because it is using SSL)

So taking both those points into consideration, I don’t understand how its responding to Dev.

I’m certainly no expert regarding the above, that’s just my understanding, but are you currently testing all your AIM payments through the dev server?


Delray Wannemcher

June 23, 2014 at 7:35 am

The last test (with screen shots) was on the live site. But when I tested on the dev site with the most recent plugin version, I received the same error. Do you think in order to accurately test I need to upgrade on production, and test there?


Josh

  • Support Staff

June 23, 2014 at 7:50 pm

Yes, or you could also test on another server where you can point to a domain that resolves to a domain name that AIM’s dev server can resolve to.


Delray Wannemcher

July 9, 2014 at 12:38 pm

The upgrade to the newest version seemed to have solved the problem.

The support post ‘Charged Multiple Times but listed as Pending Payment’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Delray Wannemcher 5 years, 4 months ago ago

Topic Tags

Tagged: ,

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.