Home Forums Event Espresso Premium Changed WordPress URL, events did not update

Changed WordPress URL, events did not update

Posted: November 13, 2012 at 7:30 pm

Stacy Tabb

November 13, 2012 at 7:30 pm

I developed a site under a subfolder to avoid interfering with the live site, then moved the index file up a level once the site was ready to go live. Apparently the Events plugin doesn’t key on the general WP settings and is not reflecting the new base URL. Is there somewhere I’m missing to make this change or do I have to go through the DB and manually update the base URL?

Stacy Tabb

November 13, 2012 at 7:37 pm

Apparently this requires a license reset? The site was developed under a subfolder until ready to go live, and now it’s just one level up. Can I have this reset, please? It just needs to be for instead of



  • Support Staff

November 13, 2012 at 11:08 pm

Hi Stacy,

Please add your license key to the General Settings page of Event Espresso. It should automatically recognize the domain now, unless you already have it there and in that case we’ll have to do some debugging to determine why it’s not activating.

Stacy Tabb

November 14, 2012 at 8:53 am

The license was already there. I removed it, readded it, and still it is showing the URL. Was it rekeyed on your end to use instead? Or am I missing something just blindingly obvious? 🙂

Jonathan Wilson

November 14, 2012 at 10:41 am

Hey Stacy,

It looks like the key is not active yet. Did you remove the key, save, then add it back and save again?

Stacy Tabb

November 14, 2012 at 10:43 am

Yes, and I’ve just done it again with no change.

Stacy Tabb

November 14, 2012 at 12:12 pm

Guys, I know you’re busy but was this license rekeyed on your end? Is there something else I need to do?

Jonathan Wilson

November 14, 2012 at 12:49 pm

May we log into the site so we can investigate further? If so, please send WordPress admin level log in credentials via the contact form on this page:

Please select the “I am sending login info as requested” department form.

Jonathan Wilson

November 14, 2012 at 1:43 pm


The reason the key is referencing is because you have the it installed on that site. If you want it to reference, then you will need to remove it from the install and enter it into the install.

Stacy Tabb

November 14, 2012 at 1:45 pm

There is no top level install. Only the index file is at the top level. The plugin isn’t capable of distinguishing the separate installation directory?


November 15, 2012 at 3:53 am

Hi Stacy,

In answer to “I appreciate you need to investigate further, but I’ve asked if the license has been updated to use the correct URL, and no one has yet answered that question.” from your email, the licence keys do not have a set address to them. What happens is when you enter the key into the site, it logs that root address and pings it back to us.

When a developer moves a site, we ask that they remove the licence key from the development install, we reset the key and then they add it back on the live install so it can find the new address and ping it back to us.

I tried to log into your site just to check it, but the login details were incorrect.

So if the site was moved (rather than copied. Please remove the licence key and save and let us know so we can reset it, then you can add it back in and save. If the site still exists at /wp, please remove the licence key from the settings there.

Stacy Tabb

November 15, 2012 at 3:56 am

Thanks. I moved the WP install up a level since that was the simplest means of resolving it.


November 15, 2012 at 4:04 am

OK I have reset the licence, please remove the key from the general settings, save, re add the key and save.

Let us know if the issue persists please.

The support post ‘Changed WordPress URL, events did not update’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso