Support

Home Forums Event Espresso Premium Can't see “Force HTTPS on Return URL” setting

Can't see “Force HTTPS on Return URL” setting

Posted: November 23, 2013 at 7:37 am


Adrienne Duncan

November 23, 2013 at 7:37 am

Like many I’m starting to have trouble w/ the PayPal gateway confirming reservations (green checkmark). According to the logs, it seems that PayPal is trying to find an SSL-encrypted page (sample below) however the setting to “force https” is not visible on my PayPal gateway settings page. I tried to look for the setting in the database to turn it off that way and couldn’t find it there either.

so not only have I not turned on the fore https, I don’t have an option to turn it off either.

Yes, IPN is enabled (clearly, from the code below) Yes, the TXN page is visible to the public and has the correct shortcodes (ditto) Now we just need the return data to confirm reservations.

Success Setting return transfer
Success Setting Timeout
Success Setting verbose mode
Errors resulting from the execution of curl transfer: SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed[11/20/2013 7:29 PM] – FAIL: IPN Validation Failed . /cgi-bin/webscr : http://www.paypal.com
IPN POST Vars from gateway:
mc_gross=28.00, protection_eligibility=Ineligible, item_number1=, payer_id=3NAD2WAYYZ42C, tax=0.00, payment_date=16:29:41 Nov 20, 2013 PST, payment_status=Completed, charset=windows-1252, mc_shipping=0.00, mc_handling=0.00, first_name=Sara, mc_fee=1.11, notify_version=3.7, custom=, payer_status=verified, business=abcdefg@gmail.com, num_cart_items=1, mc_handling1=0.00, verify_sign=AI36sk2Aln3iC.t.mla1wMizPRcQAP8qNNM-E8-LUb9ezsmfsXO7v6.A, payer_email=wxyz@gmail.com, mc_shipping1=0.00, tax1=0.00, txn_id=9AB91531TD7411037, payment_type=instant, last_name=smith, item_name1=class name . Attendee: name, receiver_email=abcdefg@gmail.com, payment_fee=1.11, quantity1=1, receiver_id=6C4P78MV36JSS, txn_type=cart, mc_gross_1=28.00, mc_currency=USD, residence_country=US, transaction_subject=, payment_gross=28.00, ipn_track_id=6d77e5d63a39,
IPN Response from gateway Server:


Dean

November 25, 2013 at 1:56 am

Hi,

The PayPal and PayPal Pro gateway options should look like this http://d.pr/i/mHsv is this not what you are seeing?


Adrienne Duncan

November 25, 2013 at 6:31 am

That’s correct. Everything else is in place except the force https. I opened the file itself and the code for that checkbox is there, but for some reason it’s not getting called.

Is there a best way to just disable https altogether? My client has no intention of using SSL on their website.


Tony

  • Support Staff

November 25, 2013 at 7:52 am

Hi Adrienne,

Generally for SSL you would need enable it, rather than having to disable it, if that makes sense.

Would it be possible for us to take a look and investigate this further?
If so please provide login details using http://eventespresso.com/send-login-details/


Tony

  • Support Staff

December 18, 2013 at 3:39 am

Hi Adrienne,

The Force SSL option will only display when you have an SSL certificate installed.

Unfortunately we have no control over the requests from Paypal.

Is the issue that when an attendee has paid and returned to the site they are marked as ‘incomplete’ still, only to refresh the page a little later and be shown as Complete?


Adrienne Duncan

December 18, 2013 at 7:46 am

Hi Tony–
Almost – the payments just don’t show as “complete” in EE. PayPal confirms the transfer and sends the confirmation email from its own system to the site owner, but EE doesn’t record it as completed, even on refresh. I manage private hosting, including other clients’ websites with ecommmerce stores connected to PayPal and they are not experiencing any difficulties with payments getting confirmed in their systems. All of the PayPal settings are per specs. i tried a solution that i discovered on this forum: putting the txn shortcode on the “thank you” page but that didn’t help either. This isn’t the first ecommerce/PayPal solution I’ve set up. 🙂 Maybe if I send you the logs, unredacted, something might jump out at you?


Josh

  • Support Staff

December 18, 2013 at 8:08 am

Hi Adrienne,

The part of the IPN log that you have posted is sufficient:

Errors resulting from the execution of curl transfer: SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed[11/20/2013 7:29 PM] – FAIL: IPN Validation Failed

To be clear, the error message is not an indication that you need an SSL certificate. It’s saying it can’t find a CA certificat. The solution involves installing a cacert.pem file and properly configuring the server to use it. A cacert.pem file can be downloaded for free and the server admin should be able to configure the server to use it in a matter of minutes. You can send them these links for more information:

http://curl.haxx.se/docs/caextract.html

http://curl.haxx.se/docs/sslcerts.html

http://board.phpbuilder.com/showthread.php?10328147-What-is-the-purpose-of-CURLOPT_SSL_VERIFYPEER-(cURL-option)


Adrienne Duncan

December 21, 2013 at 7:52 am

YES!!!!!! That solved it. I ran a purchase and the green checkmark popped right up and all of the confirmation emails/tickets were distributed.

THANK YOU!!!

Now my client is looking forward to being able to set minimum ticket numbers to go along with her Groupon deals. Any time you want to roll out that upgrade is fine by us….


Adrienne Duncan

December 21, 2013 at 11:26 am

By the way, if anyone cares, I’ve incorporated EE into this site:

http://www.wineshoeatlanta.com


Dean

December 23, 2013 at 12:14 am

Hi,

Glad it’s working now!

I love the bold images on your site, we have a showcase area you can apply for if you are interested – http://eventespresso.com/showcase/ (form is at the bottom).


Adrienne Duncan

December 23, 2013 at 9:32 am

Thanks for the tip! I just posted a detailed account of what the site is, other plugins and how I configured EE. Hope it’s useful. Have a great holiday week!

The support post ‘Can't see “Force HTTPS on Return URL” setting’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Adrienne Duncan 5 years, 8 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!