Support

Home Forums Event Espresso Premium Can't make installation work on Pantheon enviroments

Can't make installation work on Pantheon enviroments

Posted: April 9, 2018 at 1:50 pm


tnbadmin247

April 9, 2018 at 1:50 pm

Hi there,

This thread: https://eventespresso.com/topic/registration-checkout-blank-page-activating-plugin-breaks-website/
Is not quite solved yet.

Our website is hosted on Pantheon, and each time I merge to a new environment the plugin breaks the website and WP dashboard, rendering the entire website inaccessible. I can solve this by deleting and uploading the plugin again on Development branch. The problem with Pantheon is the following branches (Test and Live) don’t allow plugins to be deleted and re-uploaded again, so there is literally nothing I can do.

I tried activating and deactivating in the database, re-uploaded the file a number of times with no success.

This is proving to be mighty annoying. I should be able to just load a premium plugin, press play and have the thing work!

My annoyance aside, I still need this tool to work.

Just like the previous post (above), I get the: An ReflectionException was thrown! code EE_Registry – getClass – 1198…. error.

EE_Registry error

Anyone uses the plugin on Pantheon and could tell me if there are any special steps to make this plugin work on the platform?


Josh

  • Support Staff

April 9, 2018 at 1:58 pm

Does Pantheon have a recommended process for managing WordPress plugins? If so you’d follow that process. If the process involves using git for version control, you could use the mirrors available on Github:

https://github.com/eventespresso/event-espresso-core


tnbadmin247

April 9, 2018 at 2:15 pm

No, Pantheon doesn’t have a recommended process. Everything is handled like any other WordPress website, upload plugin, activate plugin, move on.

EE doesn’t seem to register its class on each new deploy to higher level environments. At the basic Development level I can simply re-upload the plugin again and it registers its class with a new installation/activation, but the other enviroments are read-only and only allow plugins to be activated or deactivated (no delete, upload option). But so far EE isn’t working unless I’m able to re-upload the zip folder, which seems to be to be a very complicated/long process altogether each time one needs to make the plugin work.


Josh

  • Support Staff

April 9, 2018 at 2:27 pm

What if you deactivate, then reactivate the plugin there?


tnbadmin247

April 9, 2018 at 2:33 pm

That’s what I did and it breaks.

I’m guessing EE creates it’s class at install, meaning when you upload and activate the plugin? Which is something I can’t do on Test and Live enviroments.

The files just get pushed up to Test from Dev, so it’s not the same installation process. Is there something like that in the installation process of the plugin?


Josh

  • Support Staff

April 9, 2018 at 2:42 pm

That’s not correct. The classes are instantiated during each request. It sounds like when they push the files from Test from Dev, some files do not make it to Dev. Have you compared the files from one to the other after doing the push?


tnbadmin247

April 10, 2018 at 4:01 pm

I found and fixed the problem. Thanks to your tip on “files may not have been pushed”.

Pantheon git ignores anything with “cache”, so the websites don’t become convoluted from branch to branch. EE has a cache folder ../core/services/cache which got removed everytime changes got committed and pushed upstream.

The solution was to negate that specific cache folder (!) and all works fine.
Information on gitignore on the docs: https://git-scm.com/docs/gitignore

Thanks for the tip Josh. A hassle, but fixed now.


Josh

  • Support Staff

April 11, 2018 at 8:07 am

If someone is adding overly greedy exclusion rules to their gitignores… things can break.

The support post ‘Can't make installation work on Pantheon enviroments’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 3 months, 1 week ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!