Support

Home Forums Pre-Releases Can't get Promotions Add on working

Can't get Promotions Add on working

Posted: May 31, 2015 at 1:09 pm


Nick

May 31, 2015 at 1:09 pm

I am trying to use the Pre-release promotions Add On, and can’t get it working:

Add On: Version 1.0.0.beta.063
EE4: Version 4.7.0.beta.004

There seem to be a few issues, but the first is that, when creating a new promotion code, I can’t select anything in the ‘Type’ dropdown menu.

Nick


Dean

June 1, 2015 at 6:22 am

Hi Nick,

I just ran a test with those versions and the drop down was working fine. Have you tried disabling all other addons just in there’s a conflict?


Nick

June 1, 2015 at 3:15 pm

I have tried disabling all plugins except EE4 and the Promotions Add On and it still didn’t work. As well as the issue with the drop-down menu, once one promotion code is added the ‘Add New Promotion’ button disappears.


Jonathan Wilson

June 2, 2015 at 1:25 pm

Hi Nick,

Also, there may be a theme function that is causing the issue. You can check for this by first switching to the any other theme from the wordpress.org theme repository. All of these themes pass a thorough code quality review before inclusion.


Nick

June 3, 2015 at 12:06 pm

I have tried the default WP theme (TwentyFifteen) and still experience the same issue.


Lorenzo Orlando Caum

  • Support Staff

June 3, 2015 at 12:24 pm

Hi Nick, was this current site previously using for testing a different version of Event Espresso?

If so, could you try performing a reset?

Note that this will delete all Event Espresso data and it can be found in WP-admin –> Event Espresso –> Maintenance –> Reset/Delete. Then click on the last option on the page.

One other thing is be sure that you are installing the software through the WP dashboard. I’ve seen cases where a manual install through SFTP or FTP times out and that will cause issues since there are one or more missing files.

Thanks


Lorenzo


Nick

June 3, 2015 at 2:13 pm

Mmmmh. I tried reuploading all EE4 files and all files for the promotion add on, and still the same issue.

I am not sure what you mean by “was this current site previously using for testing a different version of Event Espresso”

I don’t want to reset as I have a lot of data that I don’t want to lose.


Lorenzo Orlando Caum

  • Support Staff

June 3, 2015 at 2:16 pm

Hi, this pre-release version of the promotions add-on should not be used on a live/production site.

Do you have another testing site available?


Lorenzo


Nick

June 3, 2015 at 2:17 pm

No, only a live site.


Josh

  • Support Staff

June 3, 2015 at 3:04 pm

Hi Nick,

We ask that the Promotions add-on be tested on development and testing sites. It should not be tested on a live site.

The support post ‘Can't get Promotions Add on working’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso