Support

Home Forums Event Espresso Premium can't get access to areas of forum even though I have a licence

can't get access to areas of forum even though I have a licence

Posted: July 17, 2012 at 5:14 am


elduderino

July 17, 2012 at 5:14 am

Hi,

I’m having an issues with event espresso and want to post in the event espresso premium forum….I have a personal licence and am logged in but I still don’t seem to be able to post where I want to. Am i confused? I thought a personal licence would give me access to this forum?

Thanks

James

  • This topic was modified 10 years, 6 months ago by  Josh. Reason: Moving to premium forum


Josh

  • Support Staff

July 17, 2012 at 10:03 am

The account info for your personal license should have been sent to the same email address used when purchasing the plugin. If you can’t find this email, please fill out this form: https://eventespresso.com/contact/update-request/


elduderino

July 18, 2012 at 2:50 am

HI Josh,

Yes, that’s what I’m logging in using. I was sent an email after purchase containing login credentials. I’ve logged in to this forum using that.

I have a question about paypal redirecting after payment. I’ve been through this forum and the lagacy forum and followed every bit of advice in every thread I can find but still don’t have a fix….I wanted to post in the forums about this.

Thanks

James


Josh

  • Support Staff

July 18, 2012 at 8:27 am

I should clarify, there was a new account created for you for the new site. The account info would have been sent to the same email address that was used when the plugin was purchased. If you cannot find this email (these were sent out in June) please contact the sales team via this form so they can help you get your account updated.

If PayPal is not redirecting back to the site, check and make sure that the return URL page is publicly viewable and has the [ESPRESSO_PAYMENTS] shortcode on it.


elduderino

July 18, 2012 at 10:00 am

Hi Josh,

Thanks for the reply. I don’t seem to have been sent an email in June. I now see i got an email saying I would be getting a new username and pass but none arrived. I have sent a message using the form you suggested above.

I know this isn’t the correct place to post my question but I really could do with some advice. I am able to provide evidence that I have purchased a license if need be.

Unfortunately as I said I’ve tried everything I can find in the forums to get this working:

-My transaction page and return url are definitely publicly accessible, shortcodes are correctly in place where they should be

-I’ve checked that CURL is installed

-I’m running the site on a staging url with no other plugins installed

I’m using the simple transaction page template (recommended here https://eventespresso.com/forums/2011/09/problems-with-incomplete-payments-download/)

-I’ve got a sandbox paypal set up and have tested the ipn using this (https://eventespresso.com/forums/2011/03/testing-your-paypal-ipn/)

-I’ve checked the logs in the uploads section but can’t see any errors (although the error log is hard to read and I don’t know what to look out for)

Is there anything else I can try? I need to get this working…it’s almost there….just no payment notification and no redirect back to the site after payment is complete.

One thing I have tried but not sure I’ve got right is enabling the ipn on my merchant account (business) in the sandbox. This account is the one that I’ve entered in to event espresso’s paypal settings (payment settings->paypal settings). I’ve logged in to the paypal business account gone to profile->more options->Instant Payment Notification Preferences and enabled it using the id provided to me by event espresso in the notify_url field of the paypal debug panel. So the url providedin the notify_url field is:

http://mywebsite.com/loanpricing/?page_id=7&id=30&event_id=1&attendee_action=post_payment&form_action=payment

and I’ve entered this in to the ipn preferences of my business account (because obviously much of that query string is pertinent to an event)

http://mywebsite.com/loanpricing/?page_id=7

the page with and id of 7 is my transactions page. As i said it’s definitely accessible, it’s using the template recommended above and it’s got the [ESPRESSO_TXN_PAGE] shortcode in it.

Is what I’ve done with the paypal IPN correct? Is there anything else you can suggest. I really am out of ideas.

Thanks for your help

James


Josh

  • Support Staff

July 18, 2012 at 10:14 am

Which version of Event Espresso is installed? Look in /wp-content/uploads/espresso/logs. Is there a paypal ipn log file there? If not, change the file permissions on this directory to 777.


elduderino

July 19, 2012 at 2:52 am

Hi Josh,

I was on 3.1.15p but I’ve just upgraded to the latest 3.1.24.3. I’m now seeing a paypal ipn log file and in it are some 7 entries. The confusing thing is that none of them seem to be my data (I haven’t used the name John Smith for example) and they’re all dated 17/07/12…even though I’ve been making transactions this morning (I’ve chmod my directories to 777 btw)

anyway here’s the output:

[07/17/2012 1:27 PM] – Errors from IPN Validation:

Using BUILT-IN PHP curl methods
key = test_ipn
value = 1
key = payment_type
value = instant
key = payment_date
value = 06:26:24 Jul 17, 2012 PDT
key = payment_status
value = Completed
key = address_status
value = confirmed
key = payer_status
value = verified
key = first_name
value = John
key = last_name
value = Smith
key = payer_email
value = buyer@paypalsandbox.com
key = payer_id
value = TESTBUYERID01
key = address_name
value = John Smith
key = address_country
value = United States
key = address_country_code
value = US
key = address_zip
value = 95131
key = address_state
value = CA
key = address_city
value = San Jose
key = address_street
value = 123, any street
key = business
value = seller@paypalsandbox.com
key = receiver_email
value = seller@paypalsandbox.com
key = receiver_id
value = TESTSELLERID1
key = residence_country
value = US
key = item_name
value = something
key = item_number
value = AK-1234
key = quantity
value = 1
key = shipping
value = 3.04
key = tax
value = 2.02
key = mc_currency
value = USD
key = mc_fee
value = 0.44
key = mc_gross
value = 12.34
key = mc_gross_1
value = 9.34
key = txn_type
value = web_accept
key = txn_id
value = 247171326
key = notify_version
value = 2.1
key = custom
value = xyz123
key = charset
value = windows-1252
key = verify_sign
value = AiPC9BjkCyDFQXbSkoZcgqH3hpacAD8DOfon.KWRFpYASWO.Tz0RgpBf
Success Setting host: https://www.sandbox.paypal.com/cgi-bin/webscr
Success Setting request type to post
Success Setting post fields: test_ipn=1&payment_type=instant&payment_date=06%3A26%3A24+Jul+17%2C+2012+PDT&payment_status=Completed&address_status=confirmed&payer_status=verified&first_name=John&last_name=Smith&payer_email=buyer%40paypalsandbox.com&payer_id=TESTBUYERID01&address_name=John+Smith&address_country=United+States&address_country_code=US&address_zip=95131&address_state=CA&address_city=San+Jose&address_street=123%2C+any+street&business=seller%40paypalsandbox.com&receiver_email=seller%40paypalsandbox.com&receiver_id=TESTSELLERID1&residence_country=US&item_name=something&item_number=AK-1234&quantity=1&shipping=3.04&tax=2.02&mc_currency=USD&mc_fee=0.44&mc_gross=12.34&mc_gross_1=9.34&txn_type=web_accept&txn_id=247171326&notify_version=2.1&custom=xyz123&charset=windows-1252&verify_sign=AiPC9BjkCyDFQXbSkoZcgqH3hpacAD8DOfon.KWRFpYASWO.Tz0RgpBf&cmd=_notify-validate
Success Setting Fain On Error
Success Setting return transfer
Success Setting Timeout
Success Setting verbose mode
Errors resulting from the execution of curl transfer: SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

[07/17/2012 1:27 PM] – FAIL: IPN Validation Failed . /cgi-bin/webscr : http://www.sandbox.paypal.com
IPN POST Vars from gateway:
test_ipn=1, payment_type=instant, payment_date=06:26:24 Jul 17, 2012 PDT, payment_status=Completed, address_status=confirmed, payer_status=verified, first_name=John, last_name=Smith, payer_email=buyer@paypalsandbox.com, payer_id=TESTBUYERID01, address_name=John Smith, address_country=United States, address_country_code=US, address_zip=95131, address_state=CA, address_city=San Jose, address_street=123, any street, business=seller@paypalsandbox.com, receiver_email=seller@paypalsandbox.com, receiver_id=TESTSELLERID1, residence_country=US, item_name=something, item_number=AK-1234, quantity=1, shipping=3.04, tax=2.02, mc_currency=USD, mc_fee=0.44, mc_gross=12.34, mc_gross_1=9.34, txn_type=web_accept, txn_id=247171326, notify_version=2.1, custom=xyz123, charset=windows-1252, verify_sign=AiPC9BjkCyDFQXbSkoZcgqH3hpacAD8DOfon.KWRFpYASWO.Tz0RgpBf,
IPN Response from gateway Server:

It mentions ssl certificate problem. Do I need an ssl cert for this to work? I haven’t seen any mention of this in the documentation and I didn’t think ssl was necessary for IPN with paypal.


Josh

  • Support Staff

July 19, 2012 at 7:28 am

While it’s not absolutely necessary to install a SSL certificate for the domain, it can be useful to prevent the insecure content warnings that can pop up on the return page coming back from PayPal, but that’s a different issue than what’s going on here.

There are a few anomalies here with the IPN log. Those are sandbox tests, which might explain why it’s John Smith (sandbox accounts are not real accounts) However, what might explain things is the jump from 3.1.15.P to 3.1.24.P. The ipn log should now be recorded in /wp-content/uploads/espresso/logs. If there is not an IPN log there, that’s the directory to change to 777, not any other ones. If the PayPal gateway is in sandbox mode, it shouldn’t be throwing the CA cert error, but each server can be unique. Check with your host about getting a CA cert on the server. Most hosting companies will already have this, it’s rare to see a server set up without one. If you’re so inclined you could even hack one together yourself as outlined here

Check the IPN log in /wp-content/uploads/espresso/templates. If there isn’t one in there, you may need to try other permissions like 775.


elduderino

July 19, 2012 at 8:31 am

hi Josh,

The log is indeed being written in /wp-content/uploads/espresso/logs.I know realize that the data in the log is from ipn simulator tests I’ve done from within the sandbox. So I know that there isn’t a permissions problem if the simulator has managed to write to the file. My real transactions still don’t make an entry in the log though. I don’t the ipn is happening at all.

Is what I did with the enabling the ipn on my merchant account (business) correct? I’ve gone in to the sandbox business account (the one that I’ve linked to event espresso) and entered this url to turn on ipn. :

enabling the ipn on my merchant account (business) in the sandbox:

http://mywebsite.com/loanpricing/?page_id=7

page_id=7 is my transactions page. Is this correct?


Josh

  • Support Staff

July 19, 2012 at 8:33 am

Try setting the transactions page to a top level page. There might be a problem with the redirection. Also, check with your host about the CA cert.


elduderino

July 19, 2012 at 9:12 am

Moving the txn_page to the root is not an option unfortunately – this site is currently hosted on a staging server with lots of other sites….could this really have an effect on a redirection?

I’m going to enquire about the ssl as I don’t yet know.

My suspicion is that these aren’t the issues. I feel that somewhere there’s a setting wrong or something I am missing.


Josh

  • Support Staff

July 19, 2012 at 10:19 am

If loanpricing is the root directory of the WP install, that should be fine.

The CA cert issue is probably the issue, since that’s what the errors were indicating.


elduderino

August 23, 2012 at 3:03 am

HI there,

I’ve just got back to this project. Starting afresh I now have an ssl cert set up for my domain. I’m still experiencing the same issues. I’m using the simple txn page template as recommended by the forums. In an attempt to see what’s going on I’ve added a small script to this page to write out the $_GET and $_POST to a db. When I run a sandboxed event payment I get this back in the $_POST:

mc_gross - 0.01
protection_eligibility - Ineligible
item_number1 - payer_id - NW26YCUNQ5V8Qtax - 0.00
payment_date - 01:53:21 Aug 23, 2012
PDTpayment_status - Completed
charset - windows-1252
mc_shipping - 0.00
mc_handling - 0.00
first_name - james
mc_fee - 0.01
notify_version - 3.6
custom - payer_status - 
verifiedbusiness - james._1342530315_biz@mycompany.com
num_cart_items - 1mc_handling1 - 0.00
verify_sign - AA-RJ7go9lSJXQVxX7OIdDRLrsxAAXiPTDV7ELBt5SYkjIg5-MtnbuLupayer_email - james._1345032827_per@mycompany.commc_shipping1 - 0.00tax1 - 0.00txn_id - 8T304796F8458222Tpayment_type - instantlast_name - smithitem_name1 - Government Agencies for 18th Annual Thomson Reuters LPC Loan Conference - September 20, 2012. Attendee: james smithreceiver_email - james._1342530315_biz@mycompany.compayment_fee - 0.01quantity1 - 1receiver_id - YTZBUH2W34N4Utxn_type - cartmc_gross_1 - 0.01
mc_currency - USDresidence_country - UStest_ipn - 1transaction_subject - Shopping CartGovernment Agencies for 18th Annual Thomson Reuters LPC Loan Conference - September 20, 2012. Attendee: james smithpayment_gross - 0.01ipn_track_id - 47ddc414eba84 

The fifth line suggests that payment has been successful as far as paypal is concerned. However I’m still directed back to the thankyou page with a pyament status of incomplete. When I go in to the admin the payment for the event shows as incomplete. I’ve tried this with and without my debugging code…still no luck.

Any ideas at all?

  • This reply was modified 10 years, 5 months ago by  elduderino.


elduderino

August 23, 2012 at 5:01 am

Apologies, It seems the SSL is still not set up so this may still be the problem.

The support post ‘can't get access to areas of forum even though I have a licence’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso