Home Forums Pre-Releases Cannot use mobile app: "server response is zero-length"

Cannot use mobile app: "server response is zero-length"

Posted: May 2, 2013 at 11:26 am

Shawna Brown

May 2, 2013 at 11:26 am

I have installed the Event Espresso JSON API Plugin and followed this documentation to configure the API Settings of my WP Dashboard.  Upon doing the test link: there is just a blank screen. (note: site is in Coming Soon mode; even if I take it out of Coming Soon mode this problem persists).

I am also unable to log in to the iPhone Event Espresso HD app: it says “Sorry, can’t log in. Server response is zero-length; no data.”

This support thread indicates that “there is a bug in the current version of the API” and “We’ll be releasing an update that will fix this shortly.”

My question is: Is the reason this is not working for me b/c of the above-mentioned bug?  If so, when will the fix be released?

The ability to use the app is THE reason I was able to talk client into purchasing Event Espresso – the client has an event in two days and fully expects to use the app for check-ins, so there is a LOT riding on the ability to use the app in the next 24-48 hours.  Any help is appreciated!

MY DETAILS:WordPress 3.5.1, AIM gatewayEvent Espresso (new installation, we’ve been working to get it all set up)EE Add-Ons In Use: Calendar, Multi-Event Registration, Permissions, Social Media, Ticketing, Event Espresso JSON API… in addition, these EE-recommended plugins were also installed: WordPress HTTPS, WP Mail From II… and we are using these plugins: Scripts n Styles, Ultimate Coming Soon Page


  • Support Staff

May 2, 2013 at 11:31 am

Hi Shawna,

The bug referred to in the other thread would only affect your site if the database table prefix is different than “wp”. If that’s the case, the fix is to change line 369 in the API’s includes/resource_facades/parents/


$totalItemsInDB = intval($wpdb->get_var( "SELECT COUNT(id) FROM wp_events_attendee"));


$totalItemsInDB = intval($wpdb->get_var( "SELECT COUNT(id) FROM {$wpdb->prefix}events_attendee"));

If your WordPress database tables use the default “wp” as the prefix, then the bug wouldn’t affect your site.

You might also try temporarily deactivating any other WP plugins because there may be some code executing that may cause some issues.


May 2, 2013 at 2:15 pm

I have this exact same problem on my dev site.


  • Support Staff

May 2, 2013 at 3:42 pm


Please start a new thread and include some details that will help us investigate. The details that we need are: the URL of the site, the WordPress table prefix, and the version numbers of Event Espresso and the API you have installed. Also, please let us know if the API is set to allow public access.

Seth Shoultes

  • Support Staff

May 2, 2013 at 6:53 pm

The bug with the “wp” table prefix has been resolved and the updated JSON API add-on should be available in your account.

Shawna Brown

May 3, 2013 at 8:05 am

I installed the updates.  It did not fix the problem. The JSON feed is still blank.  Trying to log in w/ the iPhone app still says “server response is zero-length.”

We’re supposed to launch this site today and check in people using the mobile app tomorrow.  Any thoughts?


  • Support Staff

May 3, 2013 at 8:57 am

Hi Shawna,

You can try deactivating the WordPress HTTPs plugin. It’s caused conflicts on some setups before. The WordPress security plugin is a recommended alternative to secure any pages that need securing:


May 3, 2013 at 9:00 am

When I deactivated the EE SSL plugin, it all started working.



  • Support Staff

May 3, 2013 at 9:22 am

Hi there,

The Event Espresso SSL plugin is not recommended. It was an unmaintained fork of the WordPress HTTPs plugin used as a stop gap while there were some issues with WordPress HTTPs which have since been fixed.

You might try the Better WP security plugin if you need to secure any pages on the front end or the admin.

Shawna Brown

May 3, 2013 at 9:39 am

I deactivated the WordPress HTTPS plugin – then installed/set up Better WP Security plugin.

1 – The JSON feed now shows code (yay! thank you so much!)

2 – But when I try to log in w/ iPhone app, it now says “Bad username and password combination” … I’ve double-checked usernames and even reset passwords, but still not able to log in w/ the Event Espresso HD app.


  • Support Staff

May 3, 2013 at 9:46 am

Hi Shawna,

You can try double-checking the endpoint URL and make sure that is correct.

Shawna Brown

May 3, 2013 at 10:13 am

I just typed a response & it was lost…..   I’ll retype a summary:

1 – Tried as well as w/ the https:// prefix  …. “bad username and password combination”

^ 2 – Realizing that was not my API endpoint url, I also tried these (using my own details of course):  (tried with & without the /testdrive part)

and (where “qwer1234? is the session key).

…. These longer url’s both return “404 page not found”

Can you please help me determine what my endpoint URL is?

Shawna Brown

May 3, 2013 at 10:49 am

I also tried the Event Espresso test login & it says “bad username and password combination”

… this is the test login I tried:

Event Espresso Endpoint:
Login ID: myespresso
Password: mrespress

Shawna Brown

May 3, 2013 at 10:51 am

Scratch that last post… the test login DID get me in (I had mis-typed the test pw)

Still unable to log in w/ my info


  • Support Staff

May 3, 2013 at 11:02 am

I checked and it looks like:

resolves to:

so you might try that as the endpoint. It may also help to deactivate any plugins that restrict access to the site, and check the .htaccess file to make sure it isn’t set up to restrict access too.

Shawna Brown

May 3, 2013 at 11:33 am

I tried adding in the “www” – did not work: “bad username and password combination”

Also deactivated the Coming Soon plugin – did not work: “bad username and password combination”

Also checked the htaccess & I do not see anything there that would prevent access (I don’t think so, at least – what exactly should I be on the lookout for as an indication of that?)


  • Support Staff

May 3, 2013 at 2:46 pm

There are all kinds of things that can be added to an .htaccess file that will block access. A few examples:

What you might try is backing up the .htaccess file and trying without any .htaccess rules just to rule that possibility out.

If you’re still having trouble logging in, we can take a look if you create a temporary admin user account for Please be sure to check the “email password to new user” checkbox when creating the temporary admin account.

Shawna Brown

May 7, 2013 at 12:40 pm

(apologies if this posts twice, my response disappeared & I have retyped it)

I checked the .htaccess again and this is what I see:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ – [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

Since I am so very lost, I have created a temporary admin acct for

… This may be a shot in the dark, but is there any chance this may have anything to do w/ it? (see the section titled “Authentication Private Information)… the reason I think this could possibly be the problem is b/c it says:

On failure, the response will look like:
{"status":"Bad username and password combination.","status_code":401}

and that is exactly what I keep getting every time I try to log in w/ the mobile app (it says “bad username and password combination).

Thank you so much for your help so far – I feel like we’re SO close!


  • Support Staff

May 7, 2013 at 12:54 pm

Hi Shawna,

Thanks for sending those.

The htaccess file contents are the standard WP permalink rewrite rules. Nothing there to be concerned with.

I logged right in with the iPad app with the credentials you sent, so it looks to me like everything is working as it should. You’ll want to doublecheck the endpoint URL, the username, and password and make sure that they are all correctly entered. Also, it might help to be sure to wait ~1 second after keying in the last character of the password before hitting the “Login” button because there is a bit of a delay when you key a the password as it changes from a visibile character to the dot that hides what you actually typed.

Shawna Brown

May 7, 2013 at 4:22 pm

That is weird! I logged right in w/ the credentials I set for you too!  And now I know what the problem was: the passwords I’d set had a ‘#’ symbol; once I changed the passwords to NOT have a ‘#’ symbol it worked! (the pw I set for you had no ‘#’)

So that’s what it was: although WordPress allowed me to set passwords that include a ‘#’ (and I was able to log in via web browser), the Event Espresso HD app did not allow it.

Thanks again for all your help and patience – we’re just ecstatic about Event Espresso! 🙂

The support post ‘Cannot use mobile app: "server response is zero-length"’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso