Support

Home Forums Events Calendar Add-on Calendar Not Showing

Calendar Not Showing

Posted: November 5, 2012 at 8:10 pm


Sean Collishaw

November 5, 2012 at 8:10 pm

I’m working on setting up EE on a site I’m the admin for, and up until I added the calendar, things were going swimmingly. I’ve now added the calendar plugin, and when I add the shortcode to a new page, I can see the calendar when I go to preview the page. However, as soon as I publish the page, the calendar stops showing. I should also note that the WP Admin bar at the top stops showing as well.

I’ve looked at my theme’s functions.php file and jquery is being called from /wp-includes, and I can’t see anything overly obviously wrong. I’m new to all this, but have dug around in the forums and tried a lot of what is mentioned there — like adding [raw] [/raw] around the shortcode — but have had no luck. I’ve also tried deactivating all of the Plugins (except for the Event Espresso plugins) and still have had no luck.

The calendar should be showing on the page http://www.climbcrux.org/caltest/


Sean Collishaw

November 5, 2012 at 9:51 pm

I’ve continued to doodle around with this and found something interesting. If I disable “pretty permalinks” the calendar shows just fine. I’ve looked, and I do have a .htaccess file that does appear to enable mod_rewrite, so I should be able to use “pretty permalinks” or at least I’d think so, since I’m using pretty permalinks all over my site as it is. πŸ™‚

That’s all I have for now… hopefully that will make sense to someone who can explain why enabling pretty permalinks breaks my calendar. πŸ˜€


Dean

November 6, 2012 at 3:25 am

Hi Mike,

I found one potential JS conflict with the Flickr-Highslide plugin, so it is worth testing with this plugin deactivated or with the plugins js turned off for this page.


Sean Collishaw

November 6, 2012 at 7:38 am

Thanks Dean… I disabled Flickr+Highslide, and still have the same issue. I actually deactivated all plugins yesterday, except the EE plugins, and still had the same issue.


Josh

  • Support Staff

November 6, 2012 at 8:59 am

Hi Mike,

What is Permalink setting set to when this is not working, is it /%postname%/

?

Two things you might try: You could turn on debugging in the wp-config.php by changing the WP_DEBUG setting to true to see if any error messages print on the calendar page.

You could also limit the number of queries by using this shortcode on the calendar page:
[ESPRESSO_CALENDAR show_expired="false"]


Sean Collishaw

November 6, 2012 at 9:40 am

Hi Josh, I’ve tried the following:

  • /%postname%/ — doesn’t work
  • /%year%/%monthnum%/%day%/%postname%/ — doesn’t work
  • /%year%/%monthnum%/%postname%/ — doesn’t work
  • /archives/%post_id% — doesn’t work

The only way that works is to go back to default, with Pretty Permalinks = off (or defaulted). I also tried with show_expired=”false” and still get the same thing.

I did enable WP_DEBUG and got four errors. Should I paste those here, or is there a less-messy way to send those to you?


Josh

  • Support Staff

November 6, 2012 at 9:52 am

You can paste the errors in using a service like pastebin.

Also, what is the URL to the page that has the [ESPRESSO_EVENTS] shortcode on your site?


Sean Collishaw

November 6, 2012 at 9:55 am

Ooh, pastebin, that’s new! The URL is http://pastebin.com/TB0Hi28x

The shortcode is at http://www.climbcrux.org/event-registration/


Josh

  • Support Staff

November 6, 2012 at 11:04 am

Hi Mike,

The first error indicates that the apache mod_rewrite module may not be loaded.

Can you deactivate the Event Espresso requirements check plugin and we’ll go for a second opinion?

For more detailed server info, I recommend this plugin:
http://wordpress.org/extend/plugins/wordpress-php-info/

Once that’s installed, you can check the server info fromt the WP side menu under Tools>phpinfo()

On the PHPinfo() screen, under apache2handler, there will be a list of Loaded Modules. mod_rewrite should be on that list. If it is, we’ll go from there. If it isn’t, you can contact your host and ask them to install it.


Sean Collishaw

November 6, 2012 at 12:11 pm

Hey Josh… got that plugin installed, but there is no “apache2handler” section. I did search for “rewrite” and the only thing I found was:

  • url_rewriter.tags a =href,area=href,frame=src,input=src,form=,fieldse
    t=

I’ll go ahead contact my host to see if they can help out.


Sean Collishaw

November 6, 2012 at 1:10 pm

Josh, I just heard back from support, and they bring up a good point. mod_rewrite() is being enabled by the .htaccess file, and is working. If it were not working, I wouldn’t be able to go to http://www.climbcrux.org/about-us/ or http://www.climbcrux.org/links/ etc., I would be forced to use ugly links. πŸ™‚

The .htaccess file is created by wordpress when pretty permalinks are being used. That file, as it appears now, is:

BEGIN WordPress

END WordPress

rite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ – [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

END WordPress


Josh

  • Support Staff

November 6, 2012 at 1:17 pm

Hi Mike,

That’s interesting that the apache mod_rewrite module did not display anywhere in that list. It’s similar to the error that was thrown by the requirements plugin.

You may need to change the contents of the .htacess file so it reads:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

If that does not make a difference, the next step would be to check the server’s error logs right after loading up the calendar page.


Sean Collishaw

November 6, 2012 at 1:28 pm

Tried that, still no dice. πŸ™

I’ll see if host support can pull logs for me.


Sean Collishaw

November 6, 2012 at 3:09 pm

Talked with support at Portfoliositez, and they’re at a loss as well. They directed me to cpanel logs (which seem woefully lacking in detail) and the last two errors are:

[Tue Nov 06 13:49:43 2012] [error] [client 71.211.145.37] File does not exist: /home/climbcru/public_html/404.shtml
[Tue Nov 06 13:49:43 2012] [error] [client 71.211.145.37] File does not exist: /home/climbcru/public_html/caltest

Anything else? :-/


Sean Collishaw

November 6, 2012 at 3:20 pm

I’ve set up more loggin. Yay.


[06-Nov-2012 22:14:43 UTC] PHP Notice: wp_register_script was called incorrectly. Scripts and styles should not be registered or enqueued until the
wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/climbcru/public_html/wp-includes/functions.php on line 2758
[06-Nov-2012 22:14:43 UTC] PHP Notice: get_bloginfo was called with an argument that is deprecated since version 2.2! The home option is deprecated for the family of bloginfo() functions. Use the url option instead. in /home/climbcru/public_html/wp-includes/functions.php on line 2722
[06-Nov-2012 22:14:43 UTC] PHP Notice: Undefined variable: limit in /home/climbcru/public_html/wp-content/plugins/event-espresso/includes/shortcodes.php on line 803

(this file is being updated at http://climbcrux.org/wp-content/debug.log every time a page is opened. The last four entries were from loading climbcrux.org/caltest Undefined variable? Does that look promising?)


Sean Collishaw

November 6, 2012 at 3:21 pm

Yeah, just look at http://climbcrux.org/wp-content/debug.log

not sure what went wrong with my code block. sigh


Josh

  • Support Staff

November 6, 2012 at 4:14 pm

Hi Mike,

This is the error that needs to be addressed:

[06-Nov-2012 22:33:37 UTC] PHP Fatal error: Allowed memory size of 314572800 bytes exhausted (tried to allocate 40961 bytes) in /home/climbcru/public_html/wp-content/plugins/event-espresso/includes/shortcodes.php on line 215

The server is running low on memory when it’s trying to process one of Event Espresso’s shortcodes. Even though it wouldn’t seem like turning on Pretty Permalinks would take more resources to make enough of a difference, in this case, that’s what looks to be happening.

You may be able to increase the amount of memory available to WordPress by editing the wp-config.php file and using the WP_MEMORY_LIMIT setting if your host allows:

http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP


Sean Collishaw

November 6, 2012 at 11:17 pm

Hey Josh… I tried running the WP_MEMORY_LIMIT up to 128M, and then just for kicks again up to 256M, but neither work. I do keep seeing two errors that appear over and over:


[07-Nov-2012 06:13:09 UTC] PHP Notice: Undefined variable: limit in /home/climbcru/public_html/wp-content/plugins/event-espresso/includes/shortcodes.php on line 803
[07-Nov-2012 06:13:17 UTC] PHP Fatal error: Allowed memory size of 314572800 bytes exhausted (tried to allocate 40961 bytes) in /home/climbcru/public_html/wp-content/plugins/event-espresso/includes/shortcodes.php on line 215


Also, my hosting provider has confirmed that mod_rewrite is enabled, and pointed out they’re seeing error in the code:

if ( $_SERVER['HTTP_MOD_REWRITE'] )

I’m not sure which file this is, but I’ll check around to see if I can find it.


Josh

  • Support Staff

November 7, 2012 at 7:17 am

Hi Mike,

Your host may be capping the memory limit, so I’d recommend checking in with them about increasing the limit.

This code:
if ( $_SERVER['HTTP_MOD_REWRITE'] ) can be found in the Event Espresso requirements check plugin. This plugin can be deactivated so the error will not be thrown anymore.


Sean Collishaw

November 7, 2012 at 8:06 am

Thanks for all your help, Josh. This just seems to be the gift that keeps on giving! I’ve been working both sides of the support, and mentioned the memory cap to my host last night. From their PHP status in CPanel, my limit should be 300M, and I’ve upped WP_MEMORY_LIMIT to 128M and 256M both with no change. Hopefully they’ll come back with some good news.

BTW, do you guys ever sleep? πŸ™‚


Sean Collishaw

November 7, 2012 at 11:29 am

Hey Josh… Portfoliositez (my host — or psitez which is easier to type) came back with some comments.

  • We are running Apache as FastCGI/CGI. Is APACHE 2 required? If not, what settings can be done in htacess to change any PHP values in order for the plugin to work?
  • If they have an example of a WORKING calendar demo on a server using FastCGI, please have them provide a link the phpinfo file for comparision.


Sean Collishaw

November 7, 2012 at 11:32 am

Oh, I also disabled every plugin except for EE and EE Calendar, cleared the log, and went to the climbcrux.org/caltest page again to see what popped out on the logs. The only error that showed is:

[07-Nov-2012 18:24:34 UTC] PHP Notice: Undefined variable: limit in /home/climbcru/public_html/wp-content/plugins/event-espresso/includes/shortcodes.php on line 803


Josh

  • Support Staff

November 7, 2012 at 1:46 pm

Hi Mike,

This isn’t something I’ve run across before. I’m not aware of a working demo of the calendar on a site where PHP is running as a Fast CGI application.

I did some research on this and came across this article that discussed some drawbacks with this configuration when running WordPress, and they shared a solution that helped when FastCGi was running low on memory:
http://wpguru.co.uk/2012/02/the-problem-with-running-php-as-fastcgi-application/


Sean Collishaw

November 7, 2012 at 2:11 pm

Thanks Josh, I’ll forward that link to PSitez support.

I’ve also found what’s causing the problem, or at least the thing in my event causing the problem. The [LISTATTENDEES] shortcode causes the Calendar not to load! When I create an event without the [LISTATTENDEES] shortcode, the Calendar page loads fine. As soon as I add that shortcode, however, the calendar breaks.

Does that help any with the troubleshooting? I’ll forward that link along to PSitez as well. While it’s not a full-on show-stopper, we really would like to be able to show the attendees on our events page since, as a social group, many people decide whether they’ll attend or not based on who else is attending. πŸ™‚


Josh

  • Support Staff

November 7, 2012 at 3:33 pm

You know what, that’s actually a know issue with the LIST_ATTENDEES shortcode, so this probably doesn’t involve your hosting setup. What threw me was it was working without the permalinks enabled. We have an open ticket to fix the issue with the Calendar not working when LIST_ATTENDEES is used in the event description. There’s a few work arounds for this that you can use in the meantime. One is to use the older version of the calendar (1.11) that can be dowloaded here:
http://eventespresso.com/topic/alternate-calendar-versions-downloads/

There’s another workaround that I would need to test first, and it would involve adding the LISTATTENDEES shortcode directly to the registration_page_display.php template. I can test that method out and give you a code example if you’re interested in using that method as a workaround.


Sean Collishaw

November 7, 2012 at 3:58 pm

Glad we got that figured out! πŸ˜€

I’d love to see the workaround with the registration_page_display.php template. I do really like the new calendar’s ability to show details on a mouse-hover. That’s a time-saver when you’re looking through a bunch of events on the calendar.


Sean Collishaw

November 9, 2012 at 7:53 am

Hey Josh… any movement on this workaround, or guess when it might be ready? I know you’ve had a lot going on with the update, but just thought I’d check in on an update.


Sean Collishaw

November 12, 2012 at 11:56 am

Anything on this one? πŸ™‚


Josh

  • Support Staff

November 13, 2012 at 6:05 pm

Hi Mike,

I’m sorry for the delay.

I tested this out on my local server and it works for me. You can paste this into the registration_page_display.php template where you’d like that list to appear:

<div class="attendees">
<?php echo do_shortcode('[LISTATTENDEES event_identifer="' . $event_identifier . '"]'); ?>
</div>

On my site, I placed it directly below the code that displays the event’s description:

<div class="event_description clearfix">
    <?php echo espresso_format_content($event_desc); //Code to show the actual description. The WordPress function "wpautop" adds formatting to your description.   ?>
</div>
<div class="attendees">
<?php echo do_shortcode('[LISTATTENDEES event_identifer="' . $event_identifier . '"]'); ?>
</div>


Sean Collishaw

November 14, 2012 at 10:34 am

Hey Josh, thanks for getting this! I got the code in, and it’s displaying as it should be. However, when I go to the calendar, the same thing is happening as before — the page won’t display.

Do I need upgrade to EE 3.1.28.3? My site key appears to be borked, again, and I’m getting the “automatic upgrades on only one domain” error, so I can’t upgrade right now. πŸ™


Jonathan Wilson

November 14, 2012 at 3:09 pm

Hey Mike,

Did you see my post on the other topic you posted on?

I have reset your license key. Please remove the key from the field in your settings, save, then reenter the key and save again.


Josh

  • Support Staff

November 14, 2012 at 7:25 pm

Hi Mike,

When I tested the above code out on my site, the calendar continued to work as expected. While I’d recommend updating to the latest version, there wouldn’t be anything changed with the listattendees shortcode and the calendar.

Have you gone back and checked to see if the Listattendees shortcode is in any of the individual event descriptions?


Sean Collishaw

November 14, 2012 at 7:42 pm

Jonathan: I did not see that, I’ll try it though. The license key issue seems to be a daily event right now.
Josh: I’m clearly running on fumes, or something. I went through every event, and removed the listattendees shortcode a couple of days ago. However, I missed one and that was the cause. This fix works, so we now have the fun calendar installed!! Thanks for the workaround, that’s just great!

The support post ‘Calendar Not Showing’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!
[i]
[i]