Home Forums Events Calendar Add-on Calendar not showing solution

Calendar not showing solution

Posted: September 21, 2012 at 10:13 am

Mila Baumberg

September 21, 2012 at 10:13 am

Hi, I initially added the calendar shortcode [ESPRESSO_CALENDAR] to a page yet the calendar did not show up until I wrapped it in [raw] tags. I figured this might help people experiencing a similar issue.

Seth Shoultes

  • Support Staff

September 21, 2012 at 11:54 am

Thanks! That only works if the theme supports it though.

We added a function to Event Espresso that will allow you to add [raw] tag support, if your theme does not support it. Helps to keep the <p> tags from wrapping around our js scripts.

Add this to your themes function.php file:

if ( !is_admin() && function_exists( 'espresso_raw_formatter' ) ){
	remove_filter('the_content', 'wpautop');
	remove_filter('the_content', 'wptexturize');
	add_filter('the_content', 'espresso_raw_formatter', 99);

Then wrap the Event Espresso shortcodes in the [raw] tags.

Example: [raw][example_shortcode][/raw]

  • This reply was modified 8 years, 8 months ago by  Seth Shoultes. Reason: Clarification


September 24, 2012 at 9:58 am

Seth, my calendar is not showing in IE8 and Chrome but it’s fine in Firefox. I added the code above to my functions file and added the raw tags. Now, in Firefox, it shows the raw tag before and after the calendar and still not calendar in IE8 or Chrome. I’m thinking that the theme may not support those tags. Is there another solution coming??
The calendar page

Seth Shoultes

  • Support Staff

September 24, 2012 at 10:09 am

We can’t provide a solution to fix other people’s broken themes. Other than fixing the theme for you for a fee. I would highly suggest contacting the theme developer and asking them provide support for fixing their theme and/or loading JavaScript files correctly to support for ie8.


September 24, 2012 at 10:12 am

This only starting happening last week. It’s been working fine till then. I haven’t updated anything or add any new plugins.

Chris Reynolds

  • Support Staff

September 24, 2012 at 5:23 pm

Please send WordPress admin level log in credentials via the contact form on this page:

Select the “I am sending login info as requested” department form.

We can try to take a look to isolate the issue more specifically.

Chris Reynolds

  • Support Staff

September 25, 2012 at 5:45 pm

Have you noticed that the calendar works fine when you are logged in? I can see the calendar fine logged in with the account you created, but when I view the calendar logged out, I don’t see it. I suspect there’s some kind of plugin conflict going on. I will test and report back.

Chris Reynolds

  • Support Staff

September 25, 2012 at 6:11 pm

It was a conflict with the Google Analytics for WordPress plugin. When that plugin is disabled, the calendar displays fine. It may be possible to work with the settings to get this to work correctly, but I’ve left the plugin disabled for now.


September 27, 2012 at 7:11 am

Thanks Chris. At this point it’s more important to have the calendar than google analytics! I haven’t updated that plugin so I wonder why there is a conflict now. Anyway, thank you again for figuring this out for me so promptly! You guys are great!

nicholas pappagallo

September 27, 2012 at 2:18 pm

I’m trying to get the calendar to work as well over at but its not loading. Even with GA disabled it doesn’t load.

Jonathan Wilson

September 27, 2012 at 7:24 pm


Looks like there is a conflict with your theme.

The best way to track down the issue is to instal the web developer tools for Firefox or Google Chrome web browsers and look for JavaScript errors. Or ask the theme developer to fix the issue.

More here:

Seth Shoultes

  • Support Staff

September 27, 2012 at 7:43 pm


The jquery from Google that your theme is loading (, will not work with most plugins that require Jquery to be loaded properly according to the WordPress standards.

As Jonathan stated above, your theme developer will need to fix this so Jquery is loaded properly.

nicholas pappagallo

September 28, 2012 at 5:54 am

Thanks guys, my buddy works at Photocrati and said the fix is coming in their next version. They’re going to do a quick mod to my theme to take care of it. I’ll let you know if the fix worked.

nicholas pappagallo

September 28, 2012 at 10:01 am

Got it to work by commenting out a couple lines in the header. Thanks for the tip!

The support post ‘Calendar not showing solution’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!