Support

Home Forums Events Calendar Add-on Calendar loading event on wrong date

Calendar loading event on wrong date

Posted: June 25, 2012 at 1:09 pm


ctremblay

June 25, 2012 at 1:09 pm

I am using EE 3.1.24 and calendar 2.0.2. When i create an event for July, it is showing up on the june calendar until you direct to the “next month” and then go back to june. Then it has moved to the correct date. Anyone have any idea of what could be causing this? The crazy thing is that it is only happening if i create the event in the first two rows of july. If i create it in the 3 or 4th row of July it doesnt do it. When the calendar first loads and it is in the wrong month (june), i can click on it and it goes to the registration page, which has the correct date in it. It is just initially loading in the wrong place. Check it happening in action…

http://www.paintingnpinot.com/classes


Chris Reynolds

  • Support Staff

June 25, 2012 at 2:22 pm

Thanks, we’ll take a look and see if we can reproduce it.


Chris Reynolds

  • Support Staff

June 25, 2012 at 2:24 pm

@chris what happens when you add more events?


ctremblay

June 25, 2012 at 2:27 pm

Same thing. I actually had the calendar full of events, but i deleted them beacause they were created with EE 3.1.22 and i didnt know if they might be causing the problem since i updated to 3.1.24. It is just really funny, becuase if i change the event date from july 2nd, to july 15th it doesnt happen. It is only happening when it is in the first two lines of the july calendar. You still have the same admin credientials if you want to take a look at my dashboard and mess with it.


Josh

  • Support Staff

June 25, 2012 at 2:29 pm

You could try reverting back to a previous calendar version to see if the issue persists. That might help narrow this down a bit.


ctremblay

June 25, 2012 at 2:34 pm

Josh, the problem is that I am using the new version of the calendar because of the problems I had with the older version not loading correctly with multiple events on the same date and the row not expanding. It is a long story that Chis Reynolds has been helping me with. Unfortunatly I have to the new version.


Josh

  • Support Staff

June 25, 2012 at 2:57 pm

I understand, but if you can temporarily switch to the other version, that might help us troubleshoot this. I’m not able to reproduce the issue on another recent calendar version.


ctremblay

June 25, 2012 at 3:08 pm

Josh, i just switched to calendar 2.0.1 and it worked correctly. So it is something in 2.0.2


Chris Reynolds

  • Support Staff

June 25, 2012 at 3:57 pm

2.0.2 added the fixes for the other javascript loading issues. Our lead developer is working on a fix now.


ctremblay

June 26, 2012 at 12:57 pm

Just checking to see if you guys figured out what was wrong?


Jim Schuyler

June 26, 2012 at 7:42 pm

Same thing happens to me. Create an event for June 26th, let’s say, and the calendar shows “June” but the event appears two Tuesdays earlier (12th) as well as on the 26th, and if I click arrow to July and then click arrow back to June (“refresh” the month) then the “event” on the 12th goes away and everything is the way it should be. I could live with it, but my client would probably have trouble…


Josh

  • Support Staff

June 27, 2012 at 7:38 am

We are working on this. The prior iteration of the calendar had an issue where the image thumbnails were getting cut off. A few tweaks to the calendar JavaScript resolved this, but the issue as described in this post is now here as a result.

Are you using the new image thumbnail feature? If not, we could set you up with an earlier copy. Send a request to support at this domain.


ctremblay

June 27, 2012 at 11:00 am

Josh, I am using the thumbnail feature so I will just have to wait for a fix.


Josh

  • Support Staff

June 27, 2012 at 11:48 am

Hi Chris,

I was asking Jim, sorry for the confusion.


Jim Schuyler

June 27, 2012 at 12:27 pm

I am developing as we speak. I have no idea yet whether I will use the feature. However I do need to have the calendar appear “properly” for clients, so if I have to regress one version I will do so.


Josh

  • Support Staff

June 27, 2012 at 3:04 pm

Hi Jim,

There is a developer assigned to this ticket. So it might be fixed within your time frame. The original calendar did not have an image thumbnail feature. So it that’s a solution that would work for your site, let us know if you’d like a copy.


ctremblay

June 27, 2012 at 3:12 pm

Josh, I know this was to Jim, but thanks for the update. I am looking forward to the resolution.


Angie Kroll

June 28, 2012 at 3:19 pm

I’ve got the same problem with my site: fclibraries.org


Josh

  • Support Staff

June 28, 2012 at 3:38 pm

Hi Angie,

We’re working on a solution.


ctremblay

July 2, 2012 at 11:22 am

Hey Josh, I was just checking on the status of the solution. Is there an ETA?


Josh

  • Support Staff

July 2, 2012 at 3:41 pm

Hi Chris,

I don’t have an ETA. Thanks for checking in though.


Bill

July 3, 2012 at 8:45 pm

Where do I go to download calendar version 2.0.1? I can only find where to download 2.0.2 from my account screen.


Kevin Doherty

July 4, 2012 at 9:16 am

I too am having the same issue.
Any help on where I can download a prior version where this is not an issue? Or were there significant enough fixes that it would be worth waiting for the fix?
thanks in advance.


Josh

  • Support Staff

July 5, 2012 at 7:37 am

Prior versions can be downloaded here: http://eventespresso.com/topic/alternate-calendar-versions-downloads/


rsaban

July 6, 2012 at 7:08 am

Also have this problem guys, looking forward to the updated version:)


Josh

  • Support Staff

July 6, 2012 at 8:36 am

@rsaban,

Have you tried reverting to the previous point version?

http://eventespresso.com/topic/alternate-calendar-versions-downloads/


cfrost

July 6, 2012 at 6:30 pm

Same issue, looking forward to a fix. Thanks!


rsaban

July 9, 2012 at 1:00 am

Thanks Josh, the older version is working 100%

Thanks a million


ctremblay

July 9, 2012 at 9:53 am

Hey Guys, Im just checking in to see if the fix has been found? I can revert to a previous version to fix the problem of the events being shown on the wrong dates, but then i have the problem of the pictures overlapping each other if I have two events on one day. The second event covers up half of the first event. So, I can switch, but I will have problems either way. I am really looking forward to a fix. Any idea how close we are to a fix? Thanks

-Chris


Josh

  • Support Staff

July 9, 2012 at 11:21 am

We have a fix, we need to merge the new code into the next version of the calendar. We’re adding in a few other fixes and should have this out soon.


Roger

July 12, 2012 at 3:50 am

I am experiencing this same issue.
I added an event for 9-August 2012 (the second Thursday of August). When I first bring up the calendar (which defaults to the current month, July), the event shows up on 5-July (the first Thursday in July).
When I click through to the August calendar, the event shows correctly on 9-August… and when I then return to the July calendar, it no longer shows on 5-July.
I am using EE v3.1.24.1.P and Calendar v2.0.2.


Roger

July 12, 2012 at 5:33 am

More grist for the mill…
The behavior seems to be slightly browser-dependent.
– On Firefox, Safari, and Chrome, the “phantom” event shows up on first Thursday in July (5 July) and then disappears when I click through to August and back.
– On IE-9, the “phantom” event shows up on the SECOND Thursday (12 July) and then disappears when I click through to August and back.
I have tested this behavior multiple times (browser relaunches). It is a consistent phenomenon.


Roger

July 12, 2012 at 8:00 am

Just updated to Calendar v2.0.3.
Seems to have fixed the problem. Thanks.


kward

July 18, 2012 at 9:46 am

I upgraded to calendar v2.0.3 but am still having the same problem


Josh

  • Support Staff

July 18, 2012 at 9:53 am

Can you start a new thread (this one was marked as resolved) and provide more details about what is not working (possibly a link to the calendar page too?)

The support post ‘Calendar loading event on wrong date’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!
[i]
[i]