Support

Home Forums Event Espresso Premium Calendar appears in an iframe

Calendar appears in an iframe

Posted: January 5, 2013 at 7:58 pm


John Clark

January 5, 2013 at 7:58 pm

Hi

I just made a page and put the calendar shortcode on it. Strangely it appears in an iframe. Any ideas why this should be?
I have the same site locally on a testing server and when I paste the same code locally the calendar displays as it should ( it fills the page and isn’t in an iframe). It’s only when I do it to the live site that it displays strangely.
Clearly there is some difference but I don’t know where to start. The css files are identical and so to the php (famous last words). I’ve tried disabling all plug-ins (there was only one) and that didn’t change anything.
But I did notice there is a difference when viewing the source. In the one that’s displaying in an iframe the calendar is wrapped in “ tags. In the one that displays nicely there are no such tags.
Why might the calendar be wrapped in these tags in one but not the other? And, more to the point, how can I get rid of them in the online version?

Hope you can help

cheers

john


Dean

January 7, 2013 at 1:11 am

Hi John,

The forum here tends to strip html from none admins, so I am guessing a bit in that the calendar was wrapped in <p> tags?
Have you tested it with the Twentyeleven (or Twentytwelve) default theme? It sounds to me like the theme is causing an issue with the script for some reason.

If the calender works fine with the default theme you can try wrapping the calendar shortcode in raw tags, e.g.

[raw][ESPRESSO_CALENDAR][/raw]


John Clark

January 7, 2013 at 1:42 am

Hi dean

No not “p” tags but “pre” tags.

And the strange thing is that on my local testing server which uses the same theme as I use online the calendar displays fine.

I saw the “raw” wrapping suggestion the other day while browsing the forum and tried it but it made no difference.

In another mail I suggested mailing over user login info so you can get on the site and have a look.

Let me know if you have time

Cheers john


John Clark

January 7, 2013 at 1:52 am

Hi Dean

Just a quick one to say I just tried a few themes ( twentyeleven and twentytwelve) and the calendar persists in the iframe.

Cheers


Dean

January 7, 2013 at 4:15 am

Hey John,

Well pre tags would cause even more problems than p tags lol!

Sure send over login details please i’ll have a look at it

Please send them via http://eventespresso.com/contact/

Choose the “I am sending login info as requested” option and fill out the form

Please make sure you add the forum post link to aid us in case another team member picks up the email.

NOTE: login details need to be Admin level.


Dean

January 7, 2013 at 5:18 am

Hi John,

Can you send FTP credentials in the same way you sent login details please? I want to look at the theme but need FTP access to get at the functions as they are in a sub folder.

Cheers


Dean

January 7, 2013 at 5:48 am

Hi,

OK this isn’t a fix, but a workaround.

Add this to your themes style.css

pre { height: 100%; }

That will work as it extends the height of the code box which the calendar is in. It shouldnt affect anywhere else on the site as I saw nothing else wrapped in pre. Still not sure where it came from though


John Clark

January 7, 2013 at 9:57 am

Hi Dean

I have done this and it doesn’t work as it turns out that themeroller-base.css (which is taking precedence here) does some styling of “pre” tags .It is what has been setting the height at 200px!

Getting rid of that setting (obviously) makes the calendar occupy the right amount of space but it’s still in an ugly iframe!-(

Have you got any further in identifying what might be generating the “pre” tags?


John Clark

January 7, 2013 at 10:10 am

Hi Dean

a quick update. Turns out there’s loads of styling on the “pre” tag. Some comes from my themes parent style sheet, and some from themeroller-base. I’ve disabled all of it so the calendar now looks normal but I’m still intrigued as to what is causing the calendar to be wrapped in the tags in the first place.

cheers

John


John Clark

January 7, 2013 at 1:18 pm

Hi Dean

I was just doing a bit of tweaking on the calendar now that it displays properly and noticed that the text in the event boxes doesn’t wrap. Here’s a screen shot.

http://leadwhite.co.uk/images/Calendar–nowrap.png.

I’m assuming that this will have something to do with the still unexplained “pre” tags wrapping the calendar? Or perhaps it’s something else?

Anyway I thought I’d share as it may help identify the root of the problem.

cheers

John


Josh

  • Support Staff

January 7, 2013 at 2:40 pm

Hi John,

There is a simple explanation for the pre tags wrapped around the calendar: There are pre tags wrapped around the [ESPRESSO_CALENDAR] shortcode in the editor. Can you try editing the calendar page, switch to Text view, and remove the pre tags and update the page?


John Clark

January 8, 2013 at 11:48 am

Oh dear! Sorry about that! I must have copied the short code from a forum post and not noticed the tags!! Sorry to have been so careless. Hope you didn’t waste any time on this. I feel embarrassed! Thanks for your help tho’

cheers

John


John Clark

January 8, 2013 at 11:50 am

Oh dear! Sorry about that! I must have copied the short code from a forum post and not noticed the tags!! Sorry to have been so careless. Hope you didn’t waste any time on this. I feel embarrassed! Thanks for your help tho’

cheers

John

The support post ‘Calendar appears in an iframe’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  John Clark 7 years, 8 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!