Support

Home Forums Event Espresso Premium Authorize.net SIM integration – post payment transaction timeout, HELP PLEASE!

Authorize.net SIM integration – post payment transaction timeout, HELP PLEASE!

Posted: August 7, 2012 at 5:26 pm


Nicole Reineke

August 7, 2012 at 5:26 pm

I have followed the instructions in the Authorize.net setup guide, and added my Thankyou URL to the RResponse/Receipt URLs

I am able to process the transaction, but upon completion of hte Authorize.net payment, I get an error:

Authorize.Net Merchant,

Your script timed out while we were trying to post transaction results to it.

Transaction ID: 5659997674

Transaction Result: This transaction has been approved.

The following message was displayed to the customer:

——————————An error occurred while trying to report this transaction to the merchant. An e-mail has been sent to the merchant informing them of the error. The following is the result of the attempt to charge your credit card.

This transaction has been approved.

It is advisable for you to contact the merchant to verify that you will receive the product or service.


Authorize.net has been no help at all, and are tossing the blame back at Event Espresso. Anyone have experience with this?

The Thank you URL is valid and publically accessable and loads sub 1 second..


Josh

  • Support Staff

August 7, 2012 at 5:55 pm

Hi Nicole,

We can help you get this resolved. Do you have any other plugins installed besides Event Espresso? If so, and especially if there are any plugins that block incoming connections, try deactivating these and run a test.

It might help if you have a test account on authnet’s dev server to use that account, and switch to the dev/test setting in the Event Espresso>Payment Settings>Authnet SIM settings.

Here is some information from authorize.net that includes more things that can be checked: http://community.developer.authorize.net/t5/The-Authorize-Net-Developer-Blog/Relay-Response-Basics-and-Troubleshooting/ba-p/9536

You might also try this test if you have SSH access to the server. If you do, run this command from the terminal:

wget https://secure.authorize.net/gateway/transact.dll


Nicole Reineke

August 7, 2012 at 7:10 pm

Thanks for the reply. I only have Google Analytics and Constant Contact installed. disabled both, and I had the same result.

Note that the failure message appears in milliseconds, so the timeout is not the standard 10 seconds.

I have followed the troubleshooting steps in the link,
Verified the link is publicly available, and added the link to all of the Response/Receipt URLs as suggested in the article.

Unfortunately, I do not have a dev account on Authorize.net, I am a merchant only.

Any other ideas? I would be fine with bypassing the receipt entirely and redirecting to a generic page.


Josh

  • Support Staff

August 8, 2012 at 8:06 am

Hi Nichole,

Can you check a few settings? First, under Event Espresso>Payment settings>Authorize.net SIM settings, there’s a checkbox that’s labeled “Force HTTPS on Return URL”. This should be left unchecked unless there is an SSL certificate installed for this domain. If you’re not sure whether there is an SSL cert installed for this site, try loading up the web address as https: Example:

https://yoursite.com

Can you also look in the WordPress>Settings>Permalinks setting and check to see if the permalinks setting is set to a custom structure? If it is, what is the custom structure?


Nicole Reineke

August 8, 2012 at 12:01 pm

I have https unchecked, and my permalink setting was
Post name http://www.craftworkscoop.com/sample-post/

I tried changing it to the Default
Default http://www.craftworkscoop.com/?p=123
saving it, and re-runnign the card, but the failout still happens.


Josh

  • Support Staff

August 8, 2012 at 1:29 pm

Hi Nicole,

Have you tried the above suggestion to run this command from the terminal?

wget https://secure.authorize.net/gateway/transact.dll

That will help rule out whether or not the server is configured to accept inbound connections.

You might also try switching to the standard WordPress twentyeleven theme to rule out whether there is something in the theme that is causing the script to time out.


Nicole Reineke

August 9, 2012 at 5:26 pm

Hi Josh,
I ran the wget command you requested, from the server hosting the site, and this is what I got:

The following errors have occurred.(13) The merchant login ID or password is invalid or the account is inactive.

I don’t think this is surprising as no such information was passed to the call. But clearly the communications are working fine.

I did look in the site log and found several instances of authorize.net successfully access page_id 231. for example:

XX.XX.XXX.XXX – – [08/Aug/2012:14:14:24 -0400] “POST /?page_id=231&r_id=108-5022ac5aa0d80&type=authnet HTTP/1.1” 200 326652 “-” “-”
XX.XX.XXX.XXX is extta2f.authorize.net

and code 200 is a success code.

I did notice one, probably unrelated, anomaly in Espresso. A notice at the head of the config pages says: “There is an automatic update for Event Espresso available but your Site License Key has not been set.”. But looking at the configuration of Espresso, a Site License Key has been entered – it is the exact key that is in my account. Why isnt this taking?


Nicole Reineke

August 9, 2012 at 5:40 pm

Ignore the last paragraph, its all set, there was a space before the first number in my site license key.
I saved it, and reran the CC, and still have the same timeout issue.


Sidney Harrell

August 10, 2012 at 1:17 pm

Hey Nicole,
It sounds like your site might be sending a 302 redirect back to authorize.net. The user of a web browser wouldn’t even notice the redirect, but it’s not allowed by authorize.net for the receipt page. You can use the firefox plugin “live http headers” to look for the redirect.


Nicole Reineke

August 11, 2012 at 10:26 am

Our server host figured it out:

Even though Authorize.net says that they wait 10 seconds for a response from the Relay page, they don’t. It’s more like 1 to 2 seconds.

The event calendar widget down the left side of all pages is very data intensive and creates a lot of output, so I suppressed that column for page id 231, and it all started working.


Richard Stearman

August 11, 2012 at 10:52 pm

I am the person who tracked this problem down and I have started a new thread to document the responses from authorize.net as I try to get them to recognize the problem.

See my new thread here.

The support post ‘Authorize.net SIM integration – post payment transaction timeout, HELP PLEASE!’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Richard Stearman 7 years, 1 month ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!