Support

Home Forums Event Espresso Premium Authorize.net SIM integration – post payment transaction timeout

Authorize.net SIM integration – post payment transaction timeout

Posted: March 21, 2013 at 3:48 pm


chasgee1

March 21, 2013 at 3:48 pm

Read in the forums that this was an issue that wasn’t resolved with Authorize.net back in August ’12. Attempted to upload the template page that was created for the transaction page but could not activate it. Has there been any resolution to this problem?
Recently upgraded to Event Espresso is 3.1.30.7.P and WordPress 3.5.1.
Link: http://www.ahsbucs.com/lacrosse/?page_id=976
Any help would be greatly appreciated.

Charlie


Dean

March 22, 2013 at 1:55 am

Hi,

The simplified transaction page should assist with this, why could you not activate it? What was your process for installing and activating it?


chasgee1

March 22, 2013 at 11:03 am

I downloaded the zip file txnpage.zip to my computer as normal with all plugins I use. I uploaded the file and tried to activate the plugin and got this error message:

Installing Plugin from uploaded file: txnpage.zip
Unpacking the package…
Installing the plugin…
The package could not be installed. No valid plugins were found.
Plugin install failed.


Josh

  • Support Staff

March 22, 2013 at 1:31 pm

Hi there,

The transactions page template isn’t a plugin. It’s a page template that can be added to the active WordPress theme. With the Authnet SIM payment method, the transactions page template could be used, and might even help, but it would make the thank you page look very plain.

There might be a redirect occurring in this case. Can you check the Authnet SIM settings in Event Espresso>Payment settings and try checking the box that says”Force HTTPS on Return URL”. It looks like there’s an SSL certificate for your domain, so that might help.

Also, can you verify that the following response URL has been set in your Authorize.net account settings where you can enter the relay response URL:

https://www.ahsbucs.com/lacrosse/?page_id=184


chasgee1

March 22, 2013 at 1:46 pm

Hi:

I can confirm that the “Force HTTPS on Return URL” has always been checked and that the correct relay response URL is the same one above and has been so ever since I installed this program over a year ago.

Charlie


Josh

  • Support Staff

March 22, 2013 at 2:05 pm

Hi there,

From reviewing the other thread, it appears thatAuthorize.net has made it clear that they are not going to honor their “10 second” limit. so the best we can do is point you to how you can speed up your response page. The template that you downloaded will certainly speed things up, but will remove all the design elements of your site in the process.

So here are a few tips that you can use to speed up that page (and in some cases the entire site!)

1) You can install the “Better WordPress Minify” plugin. Once set up, it will combine and compress the JavaScript and CSS that gets loaded onto the page.

2) You could try creating a page template that doesn’t load a sidebar, the footer, and the background image. The customer will still have a functional page that will still match the overall look of your site, but it will load much faster without the extra images.

The support post ‘Authorize.net SIM integration – post payment transaction timeout’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 6 years, 8 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!