Support

Home Forums Event Espresso Premium Authorize.net SIM error in EE3

Authorize.net SIM error in EE3

Posted: July 12, 2016 at 11:54 am


futuremedia

July 12, 2016 at 11:54 am

The gateway and MSP are working correctly but I’m getting an error that seems to be a problem with EE3 itself. After filling out the SIM credit card page on the front end i’m sent to a blank page with the error below:

“An error occurred while trying to report this transaction to the merchant. An e-mail has been sent to the merchant informing them of the error. The following is the result of the attempt to charge your credit card.
This transaction has been approved.
It is advisable for you to contact the merchant to verify that you will receive the product or service.”

If I use AIM (which i would prefer) i simply get the “incomplete” text and red icon.

The payment processes but EE doesn’t register the transaction.

Short of the MD5 settings (which sound less stable) i’ve tried every setting in the authorize setup.

Any ideas?

Also getting the two following PHP errors, not sure if they are related:

PHP Warning: Missing argument 2 for event_espresso_price_dropdown() in
/XXX/wp-content/plugins/event-espresso/includes/functions/pricing.php on line 369, referer: http://www.specfranchiseevent.com/vendor-overview/

PHP Warning: extract() expects parameter 1 to be array, null given in
/XXX/wp-content/plugins/event-espresso/includes/functions/pricing.php on line 375, referer: http://www.specfranchiseevent.com/vendor-overview/


Josh

  • Support Staff

July 12, 2016 at 12:06 pm

Hi there,

Can you double-check the WP and FTP credentials and resend the redeem a support token form? The reason I ask is because your WordPress log in screen says the username is invalid and my FTP client returns an error with the credentials you sent.


futuremedia

July 12, 2016 at 12:52 pm

resent the form


Josh

  • Support Staff

July 12, 2016 at 1:20 pm

Thanks.

This looks like an https redirect issue where EE is sending a URL like this to Authnet:

https://www.specfranchiseevent.com/thank-you/?id=591&r_id=10-578541a589a76&type=authnet&attendee_action=post_payment&form_action=payment

but if you go to the above URL, it redirects to http.

Since you’re on WPEngine, you can open a support request for them to set the /thank-you/ page to be https. Along with that, you can ask them to turn off caching for that page.

Then, you’ll also need to make sure the following URL is set in your Authorize.net account:

https://www.specfranchiseevent.com/thank-you/

You log in to Authorize.net, goto Account > Response/Receipt URLs > Add URL and enter the above URL.


futuremedia

July 12, 2016 at 2:28 pm

have done all this, not working so far.

do i need to set Receipt Method for the Default Receipt?
if so to what? (get, post. link)


futuremedia

July 12, 2016 at 2:35 pm

i spoke too soon, it is working now. i had wp engine set the whole site to https, that seemed to do the trick!


futuremedia

July 12, 2016 at 2:40 pm

thanks for your help!


Lorenzo Orlando Caum

  • Support Staff

July 12, 2016 at 2:43 pm

Hello,

Did you have any other questions about accepting payments within Event Espresso?


Lorenzo

The support post ‘Authorize.net SIM error in EE3’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Lorenzo Orlando Caum 3 years, 3 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!