Support

Home Forums Event Espresso Premium Authorize.net Receipt page CSS not loading – Force HTTPS on Return URL option

Authorize.net Receipt page CSS not loading – Force HTTPS on Return URL option

Posted: December 15, 2013 at 8:34 pm


Debbie Warne-Jacobsen

December 15, 2013 at 8:34 pm

Hello,
I have am having an issue with authorize.net receipt page not loading the css file. I have read about this and learned I need to check “Force HTTPS on Return URL.” However I do not have this option. I do have SSL installed on the domain.

Please help!

Thank you!


Tony

  • Support Staff

December 16, 2013 at 2:48 am

Hi Debbie,

Which version of Event Espresso are you currently using?

That setting is normally in Event Espresso -> Payment Settings. (I’m assuming SIM) Authorize.net SIM Settings.

In there you should find a checkbox under the ‘hash value’ field http://d.pr/i/E19B


Debbie Warne-Jacobsen

December 16, 2013 at 5:14 am

Thank for your reply. I am using Version 3.1.36.1.P, and yes I am using the SIM Settings. The option is not anywhere in the Event Espresso –> Payment Settings –> Authroize.net SIM Settings box.
http://www.unlockingstrengths.com/files/an_sim.jpg


Tony

  • Support Staff

December 16, 2013 at 5:46 am

Can you view the page source and see if the checkbox is hidden using CSS?
(If using chrome right click on the field that the MD5 hash would go into and click ‘inspect element’, you’ll see something like http://d.pr/i/HJOZ … click on the arrow next to Li tag and see if you find force_ssl_return http://d.pr/i/lnye)

Do you have any files within wp-content/uploads/espresso/gateways/ ?


Debbie Warne-Jacobsen

December 16, 2013 at 6:25 am

It does not appear to be hidden. Here is the source code:

<label for=”authnet_md5_value”>
Authorize.net MD5 Hash value</label>
<br><input type=”text” value=”” size=”35″ name=”authnet_md5_value”>
<label for=”bypass_payment_page”>Bypass Payment Overview Page
</label>

I have nothing in wp-content/uploads/espresso/gateways/.


Tony

  • Support Staff

December 16, 2013 at 7:22 am

Strange.

Can you try de/re activating the Auth SIM gateway if that doesn’t work, de/re-activate Event Espresso itself and check again.

That checkbox not showing would generally only be from modified/old templates. Have you modified the SIM gateway at all?


Debbie Warne-Jacobsen

December 16, 2013 at 8:22 am

I have deactivated and reactivated both the Authorize.net SIM gateway and the Event Espresson plugin. No change.

I have not made any modifications to the SIM gateway.


Tony

  • Support Staff

December 16, 2013 at 8:34 am

Would it be possible for me to take a look and investigate this further?

If so can you send log-in details via http://eventespresso.com/send-login-details/


Debbie Warne-Jacobsen

December 16, 2013 at 10:04 am

I will send. I am now encountering a new issue after updating WP and EE. I am getting the following error:

The following errors have occurred.
(14) The referrer, relay response or receipt link URL is invalid.

I did not change my receipt URL on the authorize.net site.

Thanks.


Greg Phillips

December 16, 2013 at 10:57 am

We had a similar issue with a site running on WP Engine. After struggling with everything we could think of, we conceded to simply including all of the pages linked CSS and JS files AGAIN, only hardcoded with a protocol agnostic URL (e.g. ://website.com/something.css)

Considering how ugly this approach is, I would love to hear if you’re able to make any progress.


Debbie Warne-Jacobsen

December 16, 2013 at 12:38 pm

Not sure if Tony fixed this or I did. I’ve been messing with it constantly. I installed WordPress HTTPS. I then checked the “Secure Post” on the Thank you page. I then deleted the URLs listed on my Authorize.net in the Receipt/Response section so it just reads. Default Relay Response URL.

It is working now. Keeping fingers crossed.


Josh

  • Support Staff

December 16, 2013 at 12:44 pm

Hi Debbie,

It looks like there is a redirect set up somewhere (possibly in the .htaccess file?) where it doesn’t let the home page on the front end of the web site load up as https. This is likely why the force SSL option did not appear in the Payment settings.

I doubled checked that thank you page it appears to be working now that you’ve installed the https plugin and set that page to Force SSL.

The support post ‘Authorize.net Receipt page CSS not loading – Force HTTPS on Return URL option’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 5 years, 12 months ago ago

Topic Tags

Tagged: ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!