Support

Home Forums Event Espresso Premium authorization header is blocked for the app

authorization header is blocked for the app

Posted: April 2, 2019 at 1:52 pm


Nodal

April 2, 2019 at 1:52 pm

Hi,
I do have a problem with the app. It doesn’t connect to my wordpress site and give me this error: Connection error. Unable to load data.

I did a lot of research on the topic. I did a support post last year on the topic: https://eventespresso.com/topic/app-login-error-after-changing-url-for-a-ssl/

My host is asking my this:
“Can you also confirm if the application is working properly with the suPHP manager?”
They also write this to me:
“It seems that the ea-apache24-mod_env package was not installed. Please note that to test the HTTP_AUTHORIZATION header with a phpinfo () page, you must define it in the request.”

Can you help on this ?
Thanks

Is there a other way for the app to get access to the site ?
For the moment I have to turn off PHP-FastCGI (PHP-FPM) because of the app. All my server is affected by that, for all of my sites. My host also told me that: “Note that CGI deletes the headers for security reasons.”

Thanks


Josh

  • Support Staff

April 2, 2019 at 3:35 pm

Hi,

It sounds like you’ll need to move the site to a server that does allow the Basic Auth headers. When a server deletes the headers then the apps cannot authenticate the request.

In the future, if JSON Web Tokens becomes a viable option for authorization with the apps, then other types of servers may be used with the apps. For the time being the apps do require the Basic Auth headers get passed (not deleted).

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Josh 2 weeks, 1 day ago ago

Topic Tags

Tagged: ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!