Support

Home Forums Attendee Mover Add-on Attendee Mover with no events

Attendee Mover with no events

Posted: December 11, 2017 at 2:48 am


Nat J

December 11, 2017 at 2:48 am

Hi, I have read through previous forum topics about Attendee Mover not showing events and it not working. I have tried installed REST API log and tried the mover again, but no log was created and still the events do not show. I think I have tested it to find out if REST API is on. What are the next steps to try? What questions should I ask my host?


Tony

  • Support Staff

December 11, 2017 at 3:37 am

Hi Nat,

Is the site you are testing the site linked to your license key?

I checked that site and can’t see the EE REST AP endpoints there, you can check yourself by using:

{domain}/wp-json/ee/v4.8.36/events

You should see event details on that endpoint, on your site (the one linked to you key) I see:

[{"code":"json_no_route","message":"No route was found matching the URL and request method"}]

Do you have any REST plugins instaled on the site? (Other than the REST API Log)


Nat J

December 11, 2017 at 3:57 am

Hi Tony,
Yes the site is build.testmyheart.org.uk.
I have installed the WP REST API V1 and V2 and a REST API log. Does that mean that REST API is off for the site? The only other plugin family we have a part from event espresso is Woocommerce to accept donations.
Thanks
Nat


Tony

  • Support Staff

December 11, 2017 at 4:02 am

I have installed the WP REST API V1 and V2

Remove those, the REST API is built into WordPress core now so you don’t need any plugin for it to work and those are likely causing the problem.

Does that mean that REST API is off for the site?

No, the REST API is enabled otherwise you wouldn’t get any output on /wp-json/*

It means EE can’t register its ‘endpoints’ into the REST API and so EE’s data isn’t available through it.

The only other plugin family we have a part from event espresso is Woocommerce to accept donations.

Those should be fine, but it possible for one (or more) of them to conflict but start with the above and we’ll see from there.


Nat J

December 11, 2017 at 4:29 am

Hi Tony, Thank you for your speedy reply. I have removed the WP REST API plugins, I only installed them to see if that would help get it working. I have tried turning off all plugins other than event espresso and the attendee move but still no dice. I am not aware of anything changing at the hosting end as it used to work (last used a few months ago).


Tony

  • Support Staff

December 11, 2017 at 4:39 am

Ok, so now you’re getting error 500 here:

http://build.testmyheart.org.uk/wp-json/

which means something is throwing a fatal error on the RESP APIT request.

Can you either enable WP_DEBUG on the site or check the server’s error logs to see what the error is?


Nat J

December 11, 2017 at 5:31 am

Hi Tony I have turned on WP_DEBUG and looked at the error log this is the only error that comes up.

[11-Dec-2017 12:22:09 UTC] PHP Notice: WC_Cart::get_checkout_url is deprecated since version 2.5! Use wc_get_checkout_url instead. in /home/uktestmyheartorg/build.testmyheart.org.uk/wp-includes/functions.php on line 3838

I am not sure what to do now. Any ideas are very welcome.


Nat J

December 11, 2017 at 5:51 am

Update. I have fixed the deprecated problem, was due to a bit of custom code in the functions.php for redirecting after add to cart for Woocommerce. But can not see any other errors coming up that explain why the Attendee Mover is not populating with events.


Tony

  • Support Staff

December 11, 2017 at 6:31 am

For now, ignore the Attendee Mover as its a symptom of the problem and not the cause.

The problem is with the REST API on your site, the attendee mover uses that to pull a list of events, so if that’s not working then neither will the attendee mover.

If you go here: http://build.testmyheart.org.uk/wp-json/

You should see various details from your site in JOSN but nothing is displayed.

Since de-activating the REST API plugin, have you flushed your permalinks? If no go to Dashboard -> Permalinks.

Make no changes and just hit save.


Nat J

December 11, 2017 at 9:20 am

Hi Tony,

Still no dice loading the wp-json page. This is currently a build version of the website. I think this might be a problem with the host. I shall keep googling and see what I can come up with. Thanks for your help today.


Tony

  • Support Staff

December 11, 2017 at 9:38 am

I’m not so sure this is a host issue (although it may be) because it was ‘working’ with the above plugins enabled, now it’s not showing anything at all.

The next steps I would take is to de-activate all plugins and switch to a default theme, flush permalinks and retest the wp-json endpoint to confirm if it works then.

If it does re-activate each plugin one by one, testing to see it the wp-json content still loads, until you find the conflict.

We have a troubleshooting checklist available here:

https://eventespresso.com/wiki/troubleshooting-checklist/


Nat J

December 12, 2017 at 1:10 am

Hi Tony.
I have tried what you suggested this morning and the with all plugins off and a default theme the info loads on the /wp-json page but if I turn on event espresso I get this error on the page:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

I am on Version 4.9.53.p would manually reinstalling the plugion help?
Thanks
Nat


Tony

  • Support Staff

December 12, 2017 at 1:45 am

Hmmm, that’s with only EE activated? What about your theme, did you switch to a default theme during testing? (just in case there’s some kind of conflict with EE an your theme)

Have you edited EE’s files at all?

If not I wouldn’t have thought so, but it won’t hurt to try. Just de-activate and delete EE within the plugins menu (WP may say you will lose data, EE doesn’t delete your data when removing the plugin so that’s incorrect) then download the latest version from your account page and upload through Plugins -> Add new -> Upload plugin.


Nat J

December 12, 2017 at 1:58 am

Hi Tony, I am uising the wordpress twenty17 theme for testing. I deleted the event epresso from the plugins menu. Download the latest version from the accounts page, reuploaded it via FTP. Turned Event espresso back on and the page wp-json page turns up blank. Any edits to rthe EE core were in the templates part of the other theme I was using and I would have thought a fresh install would have replaced anything I could have broken. What is strange is on our Charity fundraising events website the plugin and REST API work fine and they are hosted on the same server. I am more stumped than a forest after the international lumberjack world championships.


Tony

  • Support Staff

December 12, 2017 at 2:07 am

Looking at the REST API url I see a fatal error being thrown:

Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 20480 bytes)

Which means your site is running out of memory at 40MB.

You can increase the amount of memory available to your site by following this:

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

I’d recommend using:

define( 'WP_MEMORY_LIMIT', '96M' );


Nat J

December 12, 2017 at 2:25 am

Sir Tony Warwick you are a true hero! All working and going full steam ahead. You have helped a medium sized UK charity take a step closer to improving it’s booking sytem for its heart screening service to save young lives, you are #CharityHero.

Thank you!!


Tony

  • Support Staff

December 12, 2017 at 5:39 am

Thank you for your kind words and you are more than welcome 🙂

Please do let us know if you run into any further problems.

The support post ‘Attendee Mover with no events’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Tony 2 years, 5 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!