Support

Home Forums Event Espresso Premium Attendee Mover – Critical Error on Website

Attendee Mover – Critical Error on Website

Posted: August 1, 2022 at 7:34 pm


TFA

August 1, 2022 at 7:34 pm

When trying to reassign an attendee, as soon as I click on the Attendee Mover button (from Registration Page OR view registration details pages) it throws an error [There has been a critical error on this website.]. I deactivated and reactivated the Attendee Mover plugin, also received the same error.

Wordpress 6.0
Event Espresso – 4.10.38.p
Attendee Mover Version 1.0.6.p


TFA

August 2, 2022 at 6:36 am

Error Details
=============
An error of type E_ERROR was caused in line 1024 of the file /var/www/wp-content/plugins/event-espresso-core-reg/core/admin/EE_Admin_Page.core.php. Error message: Uncaught Error: Unknown named parameter $admin_page_object in /var/www/wp-content/plugins/event-espresso-core-reg/core/admin/EE_Admin_Page.core.php:1024
Stack trace:
#0 /var/www/wp-content/plugins/event-espresso-core-reg/core/admin/EE_Admin_Page_CPT.core.php(1161): EE_Admin_Page->_route_admin_request()
#1 /var/www/wp-content/plugins/event-espresso-core-reg/core/admin/EE_Admin_Page_Init.core.php(226): EE_Admin_Page_CPT->route_admin_request()
#2 /var/www/wp-includes/class-wp-hook.php(307): EE_Admin_Page_Init->initialize_admin_page(”)
#3 /var/www/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(”, Array)
#4 /var/www/wp-includes/plugin.php(476): WP_Hook->do_action(Array)
#5 /var/www/wp-admin/admin.php(259): do_action(‘event-espresso_…’)
#6 {main}
thrown


Tony

  • Support Staff

August 2, 2022 at 1:18 pm

Hi there,

That error means your server is running PHP8 (either PHP8 or PHP8.1) which currently Event Espresso does not fully support at this time.

I recommend contacting your host (or you may also have the to do this within your control panel) and have them switch you back to PHP7.4 which is the latest version we currently support.

I will create a ticket for our developers to investigate this so that it is fixed in a future update, however, there are other areas of Event Espresso which as not PHP8 compatible so I still recommend switching down for the time being.


TFA

August 2, 2022 at 3:58 pm

Thanks. Downgraded to PHP 7.4, error is no longer an issue.


Tony

  • Support Staff

August 2, 2022 at 4:05 pm

Awesome, thank you for letting me know.

We will get the above fixed up and are working on full PHP8 compatibility, but with a codebase over 720k lines of code, it takes a little 🙂

You must be logged in to reply to this support post. Sign In or Register for an Account

Event Espresso