Support

Home Forums Event Espresso Premium Attendee Information Missing After Login

Attendee Information Missing After Login

Posted: January 23, 2018 at 3:39 pm


tooedge1

January 23, 2018 at 3:39 pm

At the Registration Check Out Page for returning Member.

1) A user fills up the form
2) Gets an Error and Prompt for Login
3) We use Captcha and ThemeMyLogin to the http_referer
4) After Login in, the attendee data goes missing

Is this a normal behaviour? Or can you please advise on how to still show the Attendee information that were previously entered before the user log ins.

Thanks.


Seth Shoultes

  • Support Staff

January 24, 2018 at 4:08 pm

Hi there,

That doesn’t sound normal. The person registering should have to login before out the form, unless the person registering is trying to use the same email address as another registered user. Is it possible to deactivate the other plugins, then try registering?


tooedge1

January 25, 2018 at 2:59 am

Hi Seth,

Thanks for your reply.

The issue above is referring to returning customers with an existing email address. We use this as a login step for returning customers.

———

More information in relation to this Registration Check Out Task :-

This is for a scenario where a returning customer is not-logged in and fills in the Registration Check Out form. The system will show an error that existing email address detected and prompt for Login. After submitted the login credentials :-

1) With Captcha Off – The Spinning Gear Icon will not stop spinning. It does seems that the login has been processed because if we just click on the “Proceed to Payment Options”, it will proceed to the next page. However, the spinning icon will not go away which lets the user assume that the login is in progress or stuck.

2) With Captcha On – The user does not gets redirected back to CheckOut Registration page. To get around this, we have to use ThemeMyLogin for the http_referer function.
All is well, however the all the data for Additional Attendee goes missing after the login process.

If the spinning gear icon can be easily fixed, while maintaining on RegistrationCheckOut and Having data for the Additional Attendees still there, that would be great too.

Any ideas to improve this please?

The goal here is to allow Existing users to login without being redirected else where and without having the need to re-fill all the data for the additional attendees.

Thanks.


tooedge1

January 28, 2018 at 11:52 pm

Hi guys,

Can I just check how this works on default with EE WPUserIntegration Addon installed:-

Scenario for a Member that is not logged in with Captcha Off :-

1) Fills up Registration Check Out Form.
2) Error will prompt that there is a matching Email Address and proceed to login.
3) Proceed with login with Spinning Gear Icon.

Question: Will the Additional Attendee information needs to be filled in again after the user successfully login as per the steps above?

Thanks.


Seth Shoultes

  • Support Staff

January 29, 2018 at 2:02 pm

Hi,

I created a couple of tickets for our developers to look into these issues.


tooedge1

January 29, 2018 at 8:59 pm

Thanks Seth,

Looking forward to the solution to this.

Thanks.


tooedge1

January 29, 2018 at 9:04 pm

I was just thinking…

Perhaps we could have a login option at the top of the form?

Eg,
If not logged in, show login prompt link/popup for returning users?
Else, hide.

Could this be integrated easily?

This will not cause the page to be reloaded hence additional attendee fields does not have to be filled in again.

Would this work?


Seth Shoultes

  • Support Staff

January 30, 2018 at 8:53 am

I think so but you will need to use some type of membership plugin that hides the form from users that are not logged in.


Tony

  • Support Staff

January 30, 2018 at 9:26 am

Hi there,

If not logged in, show login prompt link/popup for returning users?
Else, hide.

That’s basically what the ajax login form shown with reCaptcha disabled is doing.

However, right now it is throwing a JS error when attempting to hide the spinning cog on the page again (which is why the spinning cog stays on the screen), our developers will need to investigate and fix this.

The support post ‘Attendee Information Missing After Login’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 3 months, 3 weeks ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!