Support

Home Forums Event Espresso Premium Attendee Info Not Updating After Successful PayPal Transaction

Attendee Info Not Updating After Successful PayPal Transaction

Posted: July 31, 2012 at 7:28 pm


Rob Domaschuk

July 31, 2012 at 7:28 pm

EE v 3.1.21P (waiting to get access to upgrade to 3.1.25) I have a verified business PayPal account There are no caching plug-ins installedd.

It was working but the problem is getting worse… http://www.Domaschuk.com/photography-classes (site is NSFW)

When someone registers for a class, they are taken to the PayPal payment page and the payment is successfully completed. However, the attendee info is not updated. The registrant’s information shows that the payment is incomplete and that they are not registered.

If it wasn’t for the PayPal notification on my iPhone, I wouldn’t know that anyone had signed up. Additionally, the registrant doesn’t receive an email confirmation.

All my pages are public and published. In General Settings, under Email Settings, “Send email confirmations” is set to yes. Under Payment settings, only the PayPal IPN is active and “Bypass the payment confirmation screen” is set to yes.

Any help would be greatly appreciated!

Rob

  • This topic was modified 11 years, 10 months ago by  Josh. Reason: moving to correct forum topic category


Josh

  • Support Staff

July 31, 2012 at 7:42 pm

Hi Rob,

The first thing to do is update the page settings in Event Espresso>General Settings so that the notify URL page is set to this page: http://domaschuk.com/transactions/

The above linked page should not be displaying the [ESPRESSO_TXN_PAGE] shortcode, which indicates that the page setting isn’t set up correctly.

If that doesn’t correct this, run down these steps: https://eventespresso.com/wiki/troubleshooting-event-espresso/#gateways


Rob Domaschuk

August 1, 2012 at 8:00 am

Thanks so much, Josh. Made the switch, checked the link and I don’t see the shortcode, just a message that there is no ID (which is what I should be seeing)

I think that solved it. If not, I’ll update this thread.

Cheers


Rob Domaschuk

August 3, 2012 at 10:54 am

Afraid that didn’t solve it – ran through the checklist and everything is in place. I am not getting an email notice of a registration and the attendee info is still not updating.


Rob Domaschuk

August 3, 2012 at 11:12 am

I am getting this now:

ID not supplied.ID not supplied. Warning: Cannot modify header information – headers already sent by (output started at /home/domphoto/domains/domaschuk.com/public_html/wp-content/plugins/event-espresso/gateways/process_payments.php:143) in /home/domphoto/domains/domaschuk.com/public_html/wp-includes/pluggable.php on line 881

I created a new page called “Transaction” (no ‘s’) just to see if I managed to get some funky hidden character in the original. I hit “Publish” and got this error.

In fact, that is showing up whether I include Event Espresso shortcodes or just create a blank test page.

This just started happening with the upgrade to 3.1.25

  • This reply was modified 11 years, 10 months ago by  Rob Domaschuk. Reason: Added new information


Josh

  • Support Staff

August 3, 2012 at 11:45 am

Is wp_debug set to true in wp-config.php? It might help to set that to false.

For the paypal transaction not getting completed, can you check the paypal.ipn.log file in /wp-content/uploads/espresso/logs? There should be a log of each recent transaction attempt with error messages.


Rob Domaschuk

August 3, 2012 at 1:06 pm

Thanks (as always) for the fast reply, Josh!

  1. wp_debug was already set to false
  2. Nothing has been added to the log file since April of this year – there were some errors, but nothing since then. I had a transaction this morning and it’s not in the log file


Josh

  • Support Staff

August 3, 2012 at 1:15 pm

Try setting the logs folder to have 777 as permissions. Then run a test.

Error reporting might be set to displayed, which should really be set to log only on a live site. You might want to have your host look at the php.ini and set that to log only.


Rob Domaschuk

August 3, 2012 at 1:18 pm

Also, I just deactivated Event Espresso and was able to create and delete pages without any issues. If I reactivate it, I get a “Cannot Connect to Database” error or the header error I listed above.

I am going to reinstall the plugin and see if I just had a corrupted install


Rob Domaschuk

August 3, 2012 at 1:48 pm

Set it to 777 and ran a test. I looked at the log and it still isn’t showing the entry from this test. But the payment went through and, as the registrant, I got to the success page.I did not get an email confirmation.

As the organizer, however, I didn’t get the email that someone signed up and in the attendee list, the payment status doesn’t get updated.

So, I guess the critical pieces work – people can sign up and I can get the money but I really don’t want to have to go into the plug-in a couple of days to see if new registrations have happened.

Thanks Josh!


Josh

  • Support Staff

August 3, 2012 at 1:51 pm

That’s some progress anyway. With the payment page, does it show the payment as incomplete or complete?


Rob Domaschuk

August 3, 2012 at 2:00 pm

It shows incomplete.

Unfortunately, the progress was made by rolling back to the 3.1.21 version.

Here’s what I saw after registering:

Screen Shot


Josh

  • Support Staff

August 3, 2012 at 2:34 pm

If rolling back to 3.1.21 made a difference, then there might be gateway or template files in /wp-content/uploads/espresso/

If there are files in /wp-content/uploads/espresso/templates, re-name this to /wp-content/uploads/espresso/templates-old. Do the same for /wp-content/uploads/espresso/gateways


Roland

August 9, 2012 at 11:40 am

Hi, I am having a similar problem on my website http://www.dslrphotographycourses.com

tried everything for the past 6 hours – and still no luck

all payments get processed through PayPal, I can see the money in my account, but on the Thank You page “Payment Status” displays a msg “Incomplete” – every time; and “!” next to the price;

The url/msg that comes back from Paypal is for example: http://www.dslrphotographycourses.com/dates-prices/thank-you?r_id=250-5023efbf04b3a&type=paypal&tx=2NW616720P432222C&st=Completed&amt=0.35&cc=GBP&cm&item_number

so -> st=Completed …?

1) in PayPal I turned on Instant Payment Notifications (IPN) and Notification URL is set to my Thank You page.

2) also under Website Payment Preferences I set:
a) Auto Return for Website Payments to:
Auto Return is “On” and
Return URL is set to my “Thank You” page

3) Payment Data Transfer set to “On”

4) in wp-content>uploads>espresso> logs folder permissions are set to 777

I do’t know what else to try..

any ideas – anybody?

I would be really thankful!

Ro


Josh

  • Support Staff

August 9, 2012 at 11:56 am

The notify URL should be set to the page that has the transactions shortcode. This is the [ESPRESSO_TXN_SHORTCODE]. Check the page settings and verify that the page set as the notify URL has this shortcode and is publicly viewable.

Also, I would recommend following this guide on how to set up a stripped down template for the notify URL/transactions page: https://eventespresso.com/topic/problems-with-incomplete-payments-download/


Roland

August 9, 2012 at 12:29 pm

hi,

on “Payments” page I am using a [ESPRESSO_TXN_PAGE]

and on a “Thank You” page [ESPRESSO_PAYMENTS]

I don’t really get it as when I was using a basic version – before upgrading to Business version – it was all working fine..

i was testing it on my .co.uk domain and installed the business version on .com domain..

i only purchased the full business edition to get calendar and extra plugins etc..


Josh

  • Support Staff

August 9, 2012 at 3:00 pm

It might be a difference between the two servers, as the business license version is identical to the basic license code base wise.

Are there different plugins installed on this .com domain? That would be one thing to check.

Another thing that might help is to run the Event Espresso requirements check plugin to see if this server meets the minimum requirements of Event Espresso.

One other place to look is in /wp-content/uploads/espresso/logs for the paypal IPN log. If a transaction goes through, but there is an error on the payment notification, it will be recorded in this log. If there isn’t a PayPal ipn log in that location, set the permissions for that folder to 777.


bcoryer

October 15, 2012 at 8:36 pm

I am experiencing similar issue. Do we have a solution yet? Please update. Before upgrading to Business license, i receive attendee information/registration by email but now I don’t get anything. The attendee report shows incomplete payment after successful payment transaction. I am losing sales due to this problem. Please help.


Roland

October 16, 2012 at 4:15 am

hi, what I did was: deleted my original pages “transactions”, “payment successful” and the one with [ESPRESSO_EVENTS] shortcode – created new pages with slightly different names, and somehow everything went to normal and I was getting ‘successful payment’ reports in my admin panel..


Josh

  • Support Staff

October 16, 2012 at 8:51 am

Hi bcoryer,

Can you take a look at the paypal log file in /wp-content/uploads/espresso/logs to see if there are any error messages?

Also, please see this section of the troubleshooting guide for more troubleshooting tips:
https://eventespresso.com/wiki/troubleshooting-event-espresso/#gateways

Since you’re not getting the emails (likely because the Instant Payment Notification is not reaching your site), you can set the confirmation emails to be sent out before payment is made by changing the setting under Event Espresso>General Settings>Email settings.

The support post ‘Attendee Info Not Updating After Successful PayPal Transaction’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso