Support

Home Forums Event Espresso Premium Attendee/event shortcode info not showing in emails

Attendee/event shortcode info not showing in emails

Posted: February 6, 2021 at 10:09 am


Brandond123

February 6, 2021 at 10:09 am

Hello,

Using EE4. I have registration template emails sending to both event admin and event registrant. The emails received show some text in the Main Content section, but none of the shortcodes for event list or attendee details are showing.

I also have a custom question that is not showing using the [ANSWER_*] shortcode in the [ATTENDEE_LIST] section in the event admin email.

What am I missing here?

Thanks


Tony

  • Support Staff

February 8, 2021 at 6:14 am

Hi there,

Which message template are you referring to? Registration Approved?

The _LIST shortcodes will call other sections of the template so is there a [EVENT_LIST] shortcode in the main content to call the EVENT_LIST section?

With regards to [ATTENDEE_LIST], that shortcode will only be used in a template that is listing all of the attendee within the group on a single email. So the Event Admin email uses is by default but it is used within the EVENT_LIST section so [EVENT_LIST] needs to be called within Main Content.

Can you add a screenshot of the template you are editing so I can view the setup?

https://eventespresso.com/wiki/troubleshooting-checklist/#screenshots


Brandond123

February 8, 2021 at 1:49 pm

Hello,

Thanks for getting back to me. My primary setup for approved registrants is 2 parts:

  • Email the event admin with a notification of new registrants that includes the answers to 3 stock questions (Fname, Lname, email) and one custom question (mobile number) for each registrant.
  • Email the registrant with the event info (date, time) and an included Zoom link (since the seminar is virtual).

Here’s 4 screenshots, including the 2 emails received, and the backend for both. I’ve since modified the location of the log on the recipient email, but nothing else.

Backend (admin): https://lawhesselbaum.com/wp-content/uploads/2021/02/Approved-Registration-backend-admin.png
Backend (registrant): https://lawhesselbaum.com/wp-content/uploads/2021/02/Approved-Registration-backend-registrant.png
Email (admin): https://lawhesselbaum.com/wp-content/uploads/2021/02/Approved-Registration-email-admin.png
Email (registrant): https://lawhesselbaum.com/wp-content/uploads/2021/02/Approved-Registration-email-registrant.png

Let me know if that makes sense!

Thanks.


Tony

  • Support Staff

February 8, 2021 at 2:33 pm

I’m guessing you’ve create a ‘Custom Message Template’?

If so, have you set the template in the ‘Notification’ section on the event in question?

The template you are editing and the template in the emails don’t match up. For example ‘Live Zoom Webinar’ isn’t shown above the event list on the event admin email.


Brandond123

February 8, 2021 at 3:14 pm

Ah yes, I did have 2 custom templates with confusingly similar names, I will reset that and test again.

Am I using the answer shortcode for the custom question correctly? As seen here: https://lawhesselbaum.com/wp-content/uploads/2021/02/Approved-Registration-backend-admin.png


Brandond123

February 8, 2021 at 3:35 pm

Just to follow up. You were correct. I had the wrong template selected. The only thing I’m still having trouble with is the custom question answer in the approved registration admin email.

Here’s a screenshot of the custom question: https://lawhesselbaum.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-08-at-4.32.53-PM.png


Tony

  • Support Staff

February 8, 2021 at 3:50 pm

The [ANSWER_*{question_text}]` shortcode needs the ‘Question Text’ value to match exactly for the question in question.

So you need all of the text set in ‘Question text’ on the above shortcode to be included when calling the shortcode.


Brandond123

February 8, 2021 at 4:08 pm

Ok thanks. I’ll make the recommended changes.

Just to verify, does the question text need to be surrounded by { }?


Tony

  • Support Staff

February 8, 2021 at 4:20 pm

No, just the text.

[ANSWER_*Mobile Number] would be correct if the question text was just ‘Mobile Number’.


Brandond123

February 8, 2021 at 4:37 pm

Ok, got it. Thanks for the help!

The support post ‘Attendee/event shortcode info not showing in emails’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Brandond123 3 weeks, 2 days ago ago

Topic Tags

Notifications

This topic is:
pending
Do NOT follow this link or you will be banned from the site!