Support

Home Forums Event Espresso Premium App Error – Connection error. Unable to load data

App Error – Connection error. Unable to load data

Posted: March 2, 2017 at 6:11 am


Atharveda

March 2, 2017 at 6:11 am

Hi,

I am getting this error “Connection error. Unable to load data” when i try to login through the EE4 android app. I am using application password to login in the app. I searched it in the forum & did the .htaccess changes as suggested but it is still not working.

https://www.adheds.com

Please help me in resolving this issue.

Thanks,
Atharveda


Josh

  • Support Staff

March 2, 2017 at 7:40 am

Hi Atharveda,

I checked this URL and it’s returning a valid JSON response with event data:

https://www.adheds.com/wp-json/ee/v4.8.36/events

Have you stepped through the troubleshooting checklist?

https://eventespresso.com/wiki/ee4-event-apps/#troubleshooting


Atharveda

March 3, 2017 at 10:12 pm

Hi Josh,

I went through the checklist & i verified all the steps. I even talked to WPEngine & got that directive added in Nginx configuration file & also verified the .htaccess changes.

Even after doing all these changes, I am still getting the same error.

Please help me in resolving this issue.

Thanks,
Atharveda


Josh

  • Support Staff

March 6, 2017 at 12:21 pm

May I ask which version of the app is installed on your Android device?


Atharveda

March 7, 2017 at 9:22 am

The App version is: 2.24


Josh

  • Support Staff

March 7, 2017 at 12:35 pm

You can try this solution instead:

https://github.com/georgestephanis/application-passwords/wiki/Basic-Authorization-Header—-Missing


Atharveda

March 8, 2017 at 9:50 am

Hi Josh,

I tried this as well. It is also not working. 🙁
Getting the same error “Connection error. Unable to load data”.


Josh

  • Support Staff

March 8, 2017 at 10:28 am

Can you contact WPEngine support and ask them if the changes that were discussed in this Github issue have been deployed to your specific server?

https://github.com/WP-API/WP-API/issues/2512#issuecomment-280539514


Atharveda

March 8, 2017 at 11:02 am

I discussed this with WpEngine support & they confirmed that this change has been rolled out to all the servers. So this change is in place for my install.


Josh

  • Support Staff

March 8, 2017 at 11:33 am

You shouldn’t be getting any more Connection errors if they’ve got that change in place and the change is actually working.


Atharveda

March 9, 2017 at 9:35 am

This is actually very strange. They say…things are in place & working. So what do you suggest i should do now? I have to make this work anyhow.

We are totally stuck because of this issue & not able to launch our platform that we recently got developed.


Josh

  • Support Staff

March 9, 2017 at 10:53 am

You can install this plugin:
https://wordpress.org/plugins/wp-rest-api-log/
After you activate the REST API Log plugin, you can try app again. Then you can check the rest API log admin page for errors. The app actually uses the REST API to fetch events.


Atharveda

March 13, 2017 at 10:20 am

Hi Josh,

I installed the above plugin & activated. Now when i login through app, i do not see any log generated.

Is the request not even reaching to the web application?


Josh

  • Support Staff

March 13, 2017 at 2:19 pm

That may be the case. However you can check to see if anything gets logged when you visit this URL in your web browser:

https://www.adheds.com/wp-json/ee/v4.8.36/events


Atharveda

March 14, 2017 at 1:42 pm

Yes josh. I can see the complete request, headers and response logged when i visit the above url.


Josh

  • Support Staff

March 14, 2017 at 9:06 pm

That means the logging is working then. It sounds like your server is blocking the requests from the app, so you could check the access logs as well as any mod_security logs to see if any of the requests from the apps are triggering anything there.


Atharveda

March 21, 2017 at 6:33 am

Hi Josh,

I am continuously doing the follow up with them & after few days of analysis, this is what they have replied:

Hello ,
Thank you for reaching back out to WP Engine support.
I wanted to check in with you about the rules set up to allow auth.
The current rules we have in your nginx to help with the auth are:

add_header Access-Control-Allow-Origin *;
proxy_set_header Authorization “Basic am9ldXNlcjpzdXBlcnNlY3JldHBhc3N3b3Jk”;
fastcgi_pass_header Authorization;
I did try again with .htaccess rules as well based on another previous working implementation.

The ‘authorization’ cookie and argument have also been cache excluded for you.
The login does still fail after making these changes.
Because these same changes on our end have been implemented before and working can you please test out just in case the creds we are using are no longer correct? The other .htaccess was left as .htaccess2.bk .

*redacted*
If you are using another cookie with this please let us know or any other custom changes so we can add them to be excluded.
If you can double check your implementation of the plugin as well because from our end we have double checked the rules and confirmed them being set up we would need other information perhaps to work into cache exclusions.
Feel free to reach back out at any time.

  • This reply was modified 2 years, 5 months ago by  Josh. Reason: removed username and password


Josh

  • Support Staff

March 21, 2017 at 9:35 am

I removed your username and password from your above copy/paste. I also checked a request to:

https://www.adheds.com/wp-json/

in a browser, and that’s throwing an internal server error now. So that may be a result of what they changed on their end, or you have a plugin on your website that’s interfering with the WP REST API.


Atharveda

March 21, 2017 at 10:22 am

Hi Josh,

This request is working: https://www.adheds.com/wp-json/

I can see the json data in the browser.


Josh

  • Support Staff

March 21, 2017 at 1:15 pm

Maybe you can, because you’re logged into the website already. It’s throwing errors when I try the same URL:

https://www.evernote.com/shard/s4/sh/30ad731c-0b85-415a-adc5-91d09bff4bf6/e2e12ca7b600f532a288a366dffc541e


Atharveda

March 27, 2017 at 10:21 am

Hi Josh,

So WPEngine developers say that when they changed our theme to the twentyfifteen theme they were able to access the event within the app & their guess is that paid membership functionality of the theme is interfering with access to the event content.

I have done enough follow up now & i want you guys to step in & fix this issue. I am OK if i have to buy the priority token for this issue.

Please let me know how to proceed from here.

Thank You.


Josh

  • Support Staff

March 27, 2017 at 1:22 pm

Hi there,

If Event Espresso support staff gets involved with working on your WordPress theme, you’ll need to purchase enough priority support to cover the time it takes to disable the paid membership functionality of the theme. Frankly we don’t support 3rd party themes (or plugins for that matter). So you might be better off checking with the theme developer first. They may know of a way to make the paid membership functionality of their theme allow authenticated WordPress REST API requests.


Atharveda

March 28, 2017 at 7:02 am

Hi Josh,

I verified this by disabling all the plugins (Leaving only EE4 & Application Password plugin active) including paid membership but it didn’t solve the problem. So Paid membership plugin is not a problem.

When i switched to other theme leaving all plugins active, it started working. So i think problem is with my theme.

We have got our theme very much customized so they will simply ask to update the theme which we can’t. So i think they are not going to help us here.

How much time or support token do you think it will take roughly as we don’t have any other option but to get it fixed?


Josh

  • Support Staff

March 28, 2017 at 7:19 am

No idea without looking at the code. It may even be one of your customizations to the theme that’s causing the problems. Normally a properly coded WordPress theme will not affect REST API requests.


Atharveda

April 1, 2017 at 3:34 am

Hi Josh,

This issue has been fixed so i am closing this thread. The problem was in the theme.

The support post ‘App Error – Connection error. Unable to load data’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Atharveda 2 years, 4 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!