Support

Home Forums Event Espresso Premium Additional payment

Additional payment

Posted: September 2, 2019 at 10:11 am


Wassim Zeidan

September 2, 2019 at 10:11 am

I have a client who has paid part of his registration and wanted to complete the rest but when he clicks on the link in the email it takes him to a blank page.


Wassim Zeidan

September 2, 2019 at 10:13 am

This reply has been marked as private.


Tony

  • Support Staff

September 3, 2019 at 4:21 am

Hi there,

Which payment method are you using on the site?

If you check the server error logs can you see any errors being thrown from that page?

Or if you enable WP_Debug on the site using this snippet:

https://eventespresso.com/wiki/troubleshooting-checklist/#wpdebug

We can check if any errors are logged then.

In your wp-config.php file you’ll have something like define( 'WP_DEBUG', false ); the above snippet places that single line.


Wassim Zeidan

September 3, 2019 at 8:06 am

This reply has been marked as private.


Tony

  • Support Staff

September 3, 2019 at 10:48 am

That error would normally be thrown with another error.

It’s basically saying it can’t set a session because something has already sent contents to the page (which is usually from another error), on its own it isn’t an issue.

How did you add the additional charges onto the original ticket?

I’m not getting any errors so need some more details on how to reproduce the first setup if possible.


Wassim Zeidan

September 4, 2019 at 6:17 am

I added the additional charges using the EE4 3rd party plugin Price Modifier. which is listed here https://eventespresso.com/plugin_category/plugins/

I thought that that plugin could be causing the issue, so I disabled it and nothing changed.

As I mentioned in a previous reply, the problem is only with the tickets that have partial payments. If a registration has no payment, the link works perfectly


Tony

  • Support Staff

September 4, 2019 at 7:39 am

I understand it is only on partial payment, however, EE doesn’t officially support partial payments so I’m trying to reproduce the same set up you have.

So I assume the first payment was created without when the Price Modifier was not in use and now you’ve enabled it and edited the registration? The previous payment was made with Stripe, meaning it will have been a full payment for the registration at the time, so how have you edited the registration since the payment was made?

I’m not getting any errors with a partial payment applies to registrations, so I need to try an reproduce your setup.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Tony 2 weeks, 1 day ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!