Support

Home Forums Event Espresso Premium 404 Error

404 Error

Posted: February 22, 2019 at 4:08 am


KLLASC

February 22, 2019 at 4:08 am

Hi when I click on the event page “http://asc.keppelland.com/events/asc-2019/”, I get a 404 error.

Appreciate your advice?


Tony

  • Support Staff

February 22, 2019 at 4:11 am

Hi there,

Go to Dashboard -> Settings -> Permalinks.

You don’t need to do anything there, just visit the page.

Does the above link now work?


KLLASC

February 23, 2019 at 1:48 am

Hi Tony,
Navigating to Dashboard -> Settings -> Permalinks does not help.

I have to change the “Common Settings” to “Plain” though I would like to use “Post Name”.

Appreciate your advice please.

Thank you.


Tony

  • Support Staff

February 25, 2019 at 8:18 am

The above usually means that something is interfering with EE registering its post types and setting the rewrite rule for ‘pretty’ permalinks (like ‘Post Name’).

One troubleshooting step you can take is to install the Health Check plugin.

Then go to WP → Dashboard → Heath Check → Troubleshooting. There you’ll Enable Troubleshooting Mode, then once that’s activated you’ll reactivate Event Espresso only via the Health Check’s Troubleshooting item in the WP admin bar.

At that point, can you check to see if the issue persists?


KLLASC

February 28, 2019 at 4:22 am

Hi, after activating Troubleshooting and reactivating EE, I do not see the EE menu on the left. How do I test if issue is resolved then?

After deactivating Troubleshooting and setting Permalink to “Post name”, the reported issue remains, I again have to set it to “Plain”


Tony

  • Support Staff

February 28, 2019 at 4:36 am

Sounds like you are activating Event Espresso through the plugins menu and not the Troubleshooting widget on the Dashboard.

Activate Troubleshooting mode and go to the Dashboard, then enable EE through the troubleshooting widget, here – https://monosnap.com/file/3Ip6xkBfDHRLqHrAgwo1PoSYbune3z

After deactivating Troubleshooting and setting Permalink to “Post name”, the reported issue remains, I again have to set it to “Plain”

If will because nothing has changed.


KLLASC

February 28, 2019 at 11:43 pm

Hi Tony,
I activated EE through the Troubleshooting widget, not through the WordPress plugins menu.


KLLASC

February 28, 2019 at 11:48 pm

Hi,
Given the time difference in our locations, thought I should make it clearer.

After activat EE through the Troubleshooting widget, I don’t see EE in the WordPress plugins menu.


Tony

  • Support Staff

March 4, 2019 at 9:46 am

After activat EE through the Troubleshooting widget, I don’t see EE in the WordPress plugins menu.

Strange, the only time I’ve seen that is when you don’t activate it through the troubleshooting widget, or, you aren’t logged in as an administrator.

Pretty much the only time we see the above issue is when something is hooking in flushing permalinks at an unexpected time, that’s usually a plugin but can also be the theme. Troubleshooting mode is the easiest method to disable plugins without it affecting your users but if thats not working you may need to de-activate all Non-EE plugins on the site and restest that way.

I’m assuming your normal posts work when set to Post Name, is that correct?

The support post ‘404 Error’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 3 weeks ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!