Home Forums Pre-Releases Action Hooks and Filters – Observations, etc. Action Hooks and Filters – Observations, etc.

Posted: January 11, 2013 at 12:52 pm

Eric Amundson

January 11, 2013 at 12:52 pm

I was making a list of the filters and hooks and noticed some oddities and figured I’d report em in case they are an issue or anything like that. First off, I noticed there was a trend in the naming convention. “action_hook_espresso_” and “filter_hook_espresso_” was the most used prefixes, but there were a few that were missing the prefix:
* ee_seating_chart_css ee_seating_chart_js
* espresso_seating_chart_select
* ee_seating_chart_flush_expired_seats
* espresso_price_select
* espresso_seating_price_select_action
* puc_request_info_query_args-{slug}
* puc_request_info_options-{slug}
* puc_request_info_result-{slug}
* the_editor_content
* espresso_get_user_questions_where
* espresso_get_user_questions_questions (two questions?)
* expresso_get_user_questions_for_group
* espresso_get_user_questions_for_group_extra_attached
* espresso_get_user_groups_groups espresso_management_capability I also found one “espresso_social_display_buttons” (templates/event_list_display.php line 103) that was somewhat duplicated: action_hook_espresso_social_display_buttons (templates/registration_page_display.php line 120 – though not sure if a mistake or just perhaps a more descriptive name for one or the other) Found a similar one that might not actually be a type or anything: action_hook_espresso_display_offline_payment_gateway action_hook_espresso_display_offline_payment_gateway_2 But naming might not be the most intuitive. What does 2 mean? Maybe action_hook_espresso_display_offline_payment_gateway_check (?) rather than xx_2? Also action_hook_espresso_gateway_formal_name is a filter but has the action_hook_espresso prefix. (/gateways/gateway_display.php line 52) Anyway, thanks for the filters and hooks. When developing, if I find any specific locations where a filter or action would be ideal, can I request it? if so where is the best place for these and that?

  • This topic was modified 8 years, 8 months ago by  Eric Amundson. Reason: ction = action


  • Support Staff

January 11, 2013 at 12:56 pm

Hi there,

I’d recommend signing up for access for our Github repo and doing a pull request:

Please note that some of the hooks have been deprecated, and 3.2 will have a lot more hooks.

The support post ‘ Action Hooks and Filters – Observations, etc.’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso