Home Forums Event Espresso Premium 3.1.29 upgrade now produces "There was a problem finding your registration ID"

3.1.29 upgrade now produces "There was a problem finding your registration ID"

Posted: December 7, 2012 at 11:26 am


December 7, 2012 at 11:26 am

I started two days ago trying to install MER. And the problems keep multiplying. First couldn’t get MER to work, but found support posts that suggested an upgrade to 3.1.29 might resolve. So I upgraded to 3.1.29. Didn’t fix the problems I was experiencing. So I uninstalled MER. No change. Then I uninstalled EE 3.1.29, deleted files and completely reinstalled new files.

Now I cannot process any event payment. I get through to the registration form (which still has display issues) but get “There was a problem finding your Registration ID” after completing payment.

I have removed all customizations from the upload folder to make sure those weren’t the conflict, checked the known conflict list, reloaded my PEM file to the new location.

Any suggestions?

Here is a link to one of the ticket pages (I had to deactivate all links to EE events because none were working.)


  • Support Staff

December 7, 2012 at 11:32 am

Hi there,

Can you try deactivating and reactivating Event Espresso so the database update scripts can run?

Also, is the Multi Event Registration add-on installed right now?


December 7, 2012 at 12:17 pm

Deactivated. Reactivated. Server started throwing 500 errors. Host is researching. Came back up though and gave me the same error when I tried to complete a payment.

And I have not installed MER yet. Wanted to test without it to see if I could get the events functioning again.


  • Support Staff

December 7, 2012 at 12:23 pm

Hi there,

It will likely help to move the site to a different host. Many others have had problems with 500 errors on GoDaddy and moved over to another host.

We’ve actually recommended other hosts here:


December 7, 2012 at 12:44 pm

Unfortunately, this client had already paid for a long term hosting package and moving the site is not a short term option. We wanted these tickets to be up and functioning with the MER plug in for a promotion that was supposed to go out today.

Are you telling me there is nothing that can be done to fix the issue? Why was it working before the upgrade and not now?


  • Support Staff

December 7, 2012 at 1:38 pm

Hi there,

I didn’t say that there is nothing that can be done to fix the issue. If the site continues to throw the 500 internal server error, this indicates that there’s something wrong on the server’s end. That or there are PHP errors on your site.

The reason that the registration was working before the upgrade and not now is likely because the database did not get updated when the plugin was updated. Do you notice how the site will get very slow, and get to a point where it times out when you try to load a page? If this happens when you try to update the plugin and the database script doesn’t get to finish the job, the database isn’t ready to work with the new version.

I realize that it’s a hard sell to switch hosts when someone has pre-purchased hosting. If the hosting isn’t reliable enough to load pages, what else is there to do than address the server issues first? I’ve tried to visit your site a few times to help troubleshoot, and the web site either loaded very slowly or didn’t load at all.

I was working on a site yesterday that was getting the 500 internal server error, and we were able to resolve this by increasing the amount of memory available to PHP. This guide in the WordPress codex will show you how to do that (Please note that this will only work if the host allows)


December 7, 2012 at 1:56 pm

I did that yesterday and it didn’t help much. But today GoDaddy had me change file settings for the php file types and site is working much faster. (Believe me – I am trying to get them to move away from GoDaddy, but it won’t happen this weekend 🙂

Is there something I can do to make the database update so the payment page will process correctly and pull the Registration ID?


  • Support Staff

December 7, 2012 at 2:12 pm

Deactivating and reactivating will usually make the script run.

You could also try deactivating Event Espresso, dropping the tables that have “event” in them, and reactivate the plugin if this is a case where you can start fresh.


December 7, 2012 at 2:34 pm

I will try that after the server stops throwing errors …..argh…..

I checked error logs on my hosting accounting and did see this related to ee

File does not exist: /var/chroot/home/content/52/4873952/html/wp-content/plugins/event-espresso/templates/css/themeroller/themeroller-base.css/style.css

But when I navigate there, I have an old file for event espresso 3.1.20.P that does not contain a templates folder, only a gateways folder.

Would this indicate there is a problem in how I deleted and reinstalled EE?


  • Support Staff

December 7, 2012 at 3:20 pm

What method did you use to delete and reinstall Event Espresso?

Did you follow the update guide in the documentation:


December 7, 2012 at 3:26 pm

I did follow that guide for the most part. There is conflicting instructions on whether you delete the old EE before you install the new or after, so I think I deactivated it first and deleted it after. I tried to compare the customized template files to the new, but I had made so few changes to the files that I finally decided just to copy the new template files over the ones I had moved to the upload folder. After I continued to have problems, I simply deleted all of the template files in the uploads folder so it should be pulling all template files from the base 3.1.29 files.

But it appears there are still some 3.1.20 files on my host, so maybe something didn’t completely uninstall?


  • Support Staff

December 7, 2012 at 3:37 pm

When you deactivate Event Espresso, it will not automatically delete any files. So if there are files from .20 on the server, these will need to be manually deleted.


December 11, 2012 at 9:49 am


Hoping you can help me again. I am finally back to a place where EE is installed and seems to be working again, (didn’t have to drop all the database tables whew) but cannot get the MER plug in to function they way the documentation describes it.

I can get to the event list page and see add to cart link, but when I click on it it just refreshes the page and doesn’t go anywhere.

I know I am missing something, do I need to do something to set up the cart page?

Sorry – but I have read so many ee documentation articles in the last three days that my head is spinning and I just need someone sane to help stop me!!




  • Support Staff

December 11, 2012 at 11:09 am

This looks like it may be related to the JavaScript errors on the page where it says jQuery is not defined and the insecure content warnings:


These are actually related issues, because the registration page is being forced to load its elements as SSL/https, but the location where the jQuery library is being loaded from does not allow this. You can check the theme to see how it is loading the jQuery JavaScript library and alter it so that it uses the WordPress bundled version of jQuery.

Please see our blog post that discusses this for more info and code examples:

The support post ‘3.1.29 upgrade now produces "There was a problem finding your registration ID"’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso