Posts Tagged ‘requirements’

Raising the PHP Requirements for Event Espresso 4

Here at Event Espresso, our mission has always been to empower business and organization leaders with the event registration, ticketing and management tools that maximize the success of their events. While our products are constantly improving as a result of that mission, we must also continue to evaluate systems our products are built with to ensure they contribute to this mission as well. One of these dependencies is the usage of the PHP programming language.

Since the release of Event Espresso 4, back in January 2014, we have made it clear on the Requirements page that EE4 requires at least PHP 5.3. As of EE version 4.4, we will no longer support PHP 5.2. If you try activating EE 4.4 on a site running on PHP 5.2 it will simply deactivate and display a minimum PHP version is required message. This is done on purpose to prevent serious issues on your site. If you wish to continue using EE 4.4, you will have to upgrade your server to PHP 5.3 or later. If you are unable to upgrade to PHP 5.3+ right away (maybe your host is slow to respond) you can continue to use EE 4.3.1.

Please note that the PHP 5.3 series will enter an end of life cycle and receive only critical fixes as of August 14, 2014. All users of PHP are encouraged to upgrade to PHP 5.4. PHP 5.3.29 is recommended for those wishing to remain on the 5.3 series.
Create an account now and download Event Espresso 4 Decaf for free.

Why are we raising the PHP requirements for EE4?

Dropping support for PHP 5.2 was a decision we did not make lightly. In fact, we tried to delay it as long as possible. Here are the three primary reasons prompting this decision:

  1. Security
    PHP 5.2 is a dead release. It became end-of-life on January 6th, 2011 when the final version, PHP 5.2.17, was released. As the PHP website reads on that page:

    If you are using these releases, you are strongly urged to upgrade to a current version, as using older versions may expose you to security vulnerabilities and bugs that have been fixed in more recent versions of PHP.

    This is exactly the case with PHP 5.2, a version of PHP which is end of life for over 3 years. As a matter of fact, just a mere days after it became end of life a major security flaw was detected. It was fixed in PHP 5.3 but not in PHP 5.2. If you are using PHP 5.2, and your hosting provider has not patched this version, you are exposed to known security threats which are being used to attack web sites. The nature of these attacks means that your server’s firewall and/or a security component (like Admin Tools Professional) cannot protect your site. If you are using an un-patched version of PHP 5.2 your site will be hacked. The question is not if, but when. So, using PHP 5.2 may hurt your site’s security.

  2. More Efficient Code
    PHP 5.2 lacks several features necessary for modern software development, like late static binding. To cut a long story short, if we kept on supporting PHP 5.2 we could no longer maintain our software in a way that is consistent with our commitment to providing up-to-date and easy to use software. We’d be stuck in the Stone Age until we reached a point that we could no longer provide new features and updates. So, using PHP 5.2 doesn’t allow efficient software development.
  3. Quicker Feature Development
    One of the major factors in the longer release times of our EE4 products has not only been extra development time working around PHP 5.2 deficiencies, but also having to test on PHP 5.2. Eliminating support for PHP 5.2 helps us speed up release times. Therefore allowing us to develop and test new features at a much faster rate.

Why now?

Basically, we chose now as the time for dropping support because in the past year most major hosts have begun moving their customers over to newer PHP versions and are dropping support for PHP5.2. We delayed dropping support ourselves because we wanted to ensure that most of our existing customers are able to transition to newer versions of PHP fairly easily. Also, in the past year WordPress has made a number of fixes in its releases to address minor compatibility issues with PHP 5.4 and 5.5 that ensure it is fully compatible with the most recent versions of PHP.

Will my WordPress website stop working?

Upgrading your WordPress site to a new PHP version will not break the site unless you have a plugin/theme that uses a deprecated PHP function/method. Themes are less likely to have that, but plugins might. You will have to notify the plugin author of the affected plugin.

Customers can always download and install EE 4.3.2, from the pre-release channel within your account, which is compatible with PHP 5.2 until they can find a better web host.

Keep in mind WP will support sites up to PHP 5.4 (and even PHP 5.5 as of WP 3.9). So compatibility with WP is not a problem.

The only issue our customers might see in some circumstances is if they have WP_DEBUG on, plugins coded in a PHP 5.2 environment (or even PHP 5.3) might have things that throw warnings in PHP 5.4+ , but again that does not break sites if WP_DEBUG is off (which in a production environment SHOULD be off).

What if my host is still on PHP 5.2?

All the major hosts (Dreamhost, Bluehost, Hostgator, etc…) have PHP 5.3 by default.

And if there is a minor host where PHP 5.2 is the best you can have, then what’s the point with signing with a smaller and lesser known company if they cannot provide better services than big ones?

There are hosts which still offer PHP 5.2 by default but do support PHP 5.3 or 5.4 as an option. On these hosts you can ask them for the proper way to upgrade to PHP 5.3. Usually it’s a configuration option in your site’s control panel or in your .htaccess.

Even worse, there are still hosts which do not offer you any way to use PHP 5.3 or later. These hosts must be avoided at all cost. It means that the hosting company doesn’t care about investing the minimal amount of time required to properly setup their machines and ensure your security. Do you really want to trust them with your site? Would you tolerate a catering company serving stale food at your event? It’s the same question. If you’re stuck on such a host we strongly recommending moving to a decent hosting company. We have compiled a short list of quality hosts you might want to consider. Here you go, in no particular order:


As of EE 4.4, we are no longer supporting PHP version 5.2. If you cannot update to PHP version 5.2, then you cannot use EE 4.4. If your hosting company is still on PHP 5.2, you will need to have them update your server to PHP version 5.3 or greater. If they refuse, you should seriously consider switching to a different hosting provider.

Customers can always download and install EE 4.3.2, from the pre-release channel within your account, which is compatible with PHP 5.2 until they can find a better web host.

Why drop support for PHP 5.2?

  1. Security
  2. Ability to write more efficient code
  3. Quicker development of new features

Will my WordPress website still work?
Yes, your site will still work, as long as your WordPress theme and plugins are compatible with PHP 5.3+.

Host won’t update?
Move to a trusted hosting provider.


Tags: , ,
Posted in Product & News | No Comments »

Event Espresso