Support

Home Forums Event Espresso Premium Emails sending to certain registrants but not others Reply To: Emails sending to certain registrants but not others

Reply To: Emails sending to certain registrants but not others

Author Replies
Tony # Posted on April 27, 2018 at 1:48 am

Thanks for the reply. So for that registrant, it says they an email was sent, but they didn’t receive it.

Does it not also show a message for the event admin? Which message type is this (Registration Approved, Registration Pending Payment etc)

As it shows as sent in EE the problem is further downstream, in short EE builds out the content of the email, passes it over to a WP core function call wp_mail() which does its own formatting checks and then sends the email over to your server to whatever it is configured to do to send the email.

When the message shows as sent in EE it means wp_mail() returns true meaning no errors were thrown, so that usually means the problem is after that, ie your server/mailserver.

With deliverability issues we recommend using a transactional email service, we have some listed here:

https://eventespresso.com/wiki/postmark-app-mandrill-transactional-email-handling-services/

The basically hook in an tell wp mail to send the emails through their mail servers rather than the one setup by your host, we’ve found them to be more reliable than most hosts mailservers.

Also when I select resend the email, it does not go to the queue or do anything. I tried and tested for my self too and the resend function isn’t working.

There are a few different ways to resend the emails, so how are you telling EE to resend? Front-end or admin?

Can you add a screenshot of the link/button you are using?

https://eventespresso.com/wiki/troubleshooting-checklist/#screenshots

Do NOT follow this link or you will be banned from the site!