Support

Home Forums WP User Integration Security header not valid – API information correct Reply To: Security header not valid – API information correct

Reply To: Security header not valid – API information correct

Author Replies
Tony # Posted on April 20, 2018 at 4:12 am

Hi there,

I’ve seen the source code on my registration page and there are some references to “http” in there… could that be what’s causing the security issue?

Usually not but I just checked your site on the payment step and only see one reference to HTTP which is in an error message.

Can you re-enable PayPal Pro so I can take a look?

Is there a workaround here?

We don’t know what the problem is yet so can’t really answer that.

99% of the time, a security header is no valid error is from invalid credentials, you mentioned you’ve checked those, have you’ve checked for spaces before/after all of the credentials?

To use PayPal Pro you need a pro account with PayPal, do you have one? (There’s a monthly fee from PayPal for that account, if your account does not currently incur a monthly fee you don’t have the correct account type with PayPal to use Pro)

Whilst you are free to use whichever payment method you prefer, PayPal Pro (along with any ‘on-site’ payment method) increases your PCI compliance scope by a huge amount so I’m just checking you are also aware of that?

Can I embed the form on a secure page? Not sure if that would help, since the seemingly non-secure code is IN the form, but it would be worth a shot at this point?

No, and there should be no need to, there’s no reason why the ‘normal’ page your using now shouldn’t work.

Do NOT follow this link or you will be banned from the site!